[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] parse-datetime: do some more renaming

From: Eric Blake
Subject: Re: [PATCH] parse-datetime: do some more renaming
Date: Thu, 07 Oct 2010 08:06:54 -0600
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100921 Fedora/3.1.4-1.fc13 Mnenhy/0.8.3 Thunderbird/3.1.4

On 10/05/2010 06:00 PM, Paul Eggert wrote:
On 10/05/10 14:00, Eric Blake wrote:
Is that the correct historical name, or should this be worded:

@code{parse_datetime} started life as @code{getdate}, as originally

Perhaps that would be better.  I don't know what its name was
originally, though; somebody would have to check.

Per coreutils' ChangeLog:

+Sun May 19 18:42:09 1991 David J. MacKenzie (djm at churchy.gnu.ai.mit.edu)
+ * touch.c: Renamed getdate to get_date to avoid SVR4 conflict.

Should we also mention the non-thread-safe getdate() POSIX function, and
mention how the two differ?

A brief mention of that would be OK, too.  Wouldn't spend a lot
of time on it.

It's implicitly mentioned by explaining the getdate->get_date rename :)

I've checked in this:
diff --git i/ChangeLog w/ChangeLog
index 7257a90..f3ca2ca 100644
--- i/ChangeLog
+++ w/ChangeLog
@@ -1,5 +1,9 @@
 2010-10-07  Eric Blake  <address@hidden>

+       docs: update parse-datetime history
+       * doc/parse-datetime.texi (Authors of parse_datetime): Better
+       documentation of this function's history and alternatives.
        cygwin: use more robust version check
        * m4/memmem.m4 (gl_FUNC_MEMMEM_SIMPLE, gl_FUNC_MEMMEM): Don't
        exclude an eventual cygwin 1.9.1.
diff --git i/doc/parse-datetime.texi w/doc/parse-datetime.texi
index b0a8340..8218d9f 100644
--- i/doc/parse-datetime.texi
+++ w/doc/parse-datetime.texi
@@ -543,15 +543,19 @@ Authors of parse_datetime
 @cindex MacKenzie, David
 @cindex Meyering, Jim
 @cindex Eggert, Paul
address@hidden was originally implemented by Steven M. Bellovin
address@hidden started life as @code{getdate}, as originally
+implemented by Steven M. Bellovin
 (@email{smb@@research.att.com}) while at the University of North Carolina
 at Chapel Hill.  The code was later tweaked by a couple of people on
 Usenet, then completely overhauled by Rich $alz (@email{rsalz@@bbn.com})
 and Jim Berets (@email{jberets@@bbn.com}) in August, 1990.  Various
revisions for the @sc{gnu} system were made by David MacKenzie, Jim Meyering,
-Paul Eggert and others, including renaming it to @code{get_date} and
-then to @code{parse_datetime}
-to avoid confusion with the Posix function @code{getdate}.
+Paul Eggert and others, including renaming it to @code{get_date} to
+avoid a conflict with the alternative Posix function @code{getdate},
+and a later rename to @code{parse_datetime}.  The Posix function
address@hidden can parse more locale-specific dates using
address@hidden, but relies on an environment variable and external
+file, and lacks the thread-safety of @code{parse_datetime}.

 @cindex Pinard, F.
 @cindex Berry, K.

Eric Blake   address@hidden    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]