[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build problems

From: Nigel Rumens
Subject: Re: build problems
Date: Wed, 09 Jul 2008 08:39:02 +0100
User-agent: Thunderbird (X11/20080501)


Just seen this thread checked my install (which simply worked when I tested it)

It seems that the reason it worked for me was that I had a run-mozilla.sh script left over from the install of the previous (non-working) tarball.

So I blew everything away completely and re-installed. Then I hit the same problem as Gabriele. A few changes from run-mozilla.sh to run-icecat.sh and everything was fine.

Just though I'd everyone know


gabriele balducci wrote:
dear giuseppe,

gabriele balducci wrote:
But then, at run time, I get:

  Cannot find mozilla runtime directory. Exiting.
Can you please tell me how you execute icecat? Are you executing from the same directory where the icecat file is located (simply running ./icecat)?

the above error happens when I run the icecat script both from its
directory, as ./icecat, and from any other directory, using its complete
path. As far as I can see, the icecat script tries to run a
run-mozilla.sh script, which, however, is not installed
anywhere. Instead, a run-icecat.sh script is installed, which I guess
should be referenced in the icecat script in place of run-mozilla.sh.

host> wget http://gnuzilla.gnu.org/download/icecat-3-g1.tar.bz2
host> md5sum icecat-3-g1.tar.bz2
ef1a7dea4320dffe3b7f0a09fc5c737b  icecat-3-g1.tar.bz2
So: am I using the wrong tarball or am I misusing the md5sum command?
This is correct MD5 checksum for latest version I uploaded.

A second minor question: did the icecat logo disappear form icecat-3?
Of course not, it is showed in the about form :)

I am very sorry for my poor precision using words. I said icecat logo,
while I was meaning icecat icon: before 3, there was a default.xpm
pixmap representing the icecat logo to which icecat was iconified. Using
the binary distro icecat-3.0-g1-i386.tar.bz2 (for hacking on the present
problems) I have noticed that icecat iconifies now to a generic
default??.png icon, representing the earth.

If you are having troubles with the logo then I think you misconfigured something in the branding directory. Please try to re-compile it without passing any additional argument to ./configure, what is inside .mozconfig is correct, to be sure IceCat is recompiled go in the browser directory and execute "make clean" before the complete "make" in the root directory.

I just downloaded and built a tarball with the following script:
(md5 checksum: ef1a7dea4320dffe3b7f0a09fc5c737b  icecat-3-g1.tar.bz2)

     set -x
     rm -rf icecat-3-g1
     tar jxf icecat-3-g1.tar.bz2
     cd icecat-3-g1
     cat >> .mozconfig <<EOF
     ac_add_options --disable-dbus
     sed -i -e's|\-\-prefix=.*$|--prefix=/usr/local/icecat|' .mozconfig
     make install
     exit 0

The only changes to .mozconfig are the two shown above:

=> I do not have dbus support and configure chokes if I do not disable
=> changed the prefix in order to install under a completely isolated
   tree, at least until things will be fixed

I built on two different gnu/linux boxes with different archs (x86_64
and x86): the result is the same, i.e. the icecat script wants to run
run-mozilla.sh, which is not installed anywhere, while it should run
run-icecat.sh. As a matter of fact, changing run-mozilla.sh to
run-icecat.sh in the icecat script fixes things. But, should not this be
done at some point by the build/install procedure?

You can crosscheck my results with the script above

Any feedback will be warmly appreciated

thanks a lot for icecat


reply via email to

[Prev in Thread] Current Thread [Next in Thread]