[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#21879: WeeChat does not start

From: Luis Felipe López Acevedo
Subject: bug#21879: WeeChat does not start
Date: Wed, 18 Nov 2015 15:05:17 -0500
User-agent: Roundcube Webmail/1.0.6

On 2015-11-18 12:06, address@hidden wrote:

Luis Felipe López Acevedo <address@hidden> skribis:

I installed WeeChat 1.3 using Guix 0.9.0 on Debian 8, but It doesn't
start when I run it. I get this error instead:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 563, in <module>

On closer inspection, this comes from the fact that Weechat looks for a
‘python’ executable in $PATH.  See src/plugins/python/weechat-python.c
in Weechat.

In your case, it ended up running Debian’s Python, which then failed for
reasons that are unclear to me.

I believe this is fixed by a9346fa and 7be4a4b.  Could you confirm?
You could run ‘guix pull’ or pull from a current ‘master’ checkout.

In a different machine, but still Debian 8 and Guix 0.9.0:

1. I ran 'guix pull'
2. Installed weechat

I get the same error.

Luis Felipe López Acevedo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]