[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#21879: WeeChat does not start

From: Luis Felipe López Acevedo
Subject: bug#21879: WeeChat does not start
Date: Sun, 29 Nov 2015 09:12:01 -0500
User-agent: Roundcube Webmail/1.0.6

On 2015-11-29 06:01, address@hidden wrote:
Cyril Roelandt <address@hidden> skribis:

On 11/18/2015 10:22 PM, Ludovic Courtès wrote:
Could you double-check what’s happening, possibly running it through
strace to see if it’s actually executing /usr/bin/python?

I'm pretty sure it does that. It even loads libraries from the Debian
Python path, that is why it tries to import a Debian-specific module.

I tried this:

  guix environment --container --ad-hoc weechat strace coreutils \
     findutils sed grep less --expose=$(which false)=/usr/bin/python

which installs ‘false’ as /usr/bin/python, but it still works fine.

Felipe, could you report the values of the ‘PYTHONPATH’, ‘PATH’, and
‘LD_LIBRARY_PATH’ variables on your system?

Oh, I didn't get Cyril's messages on the bug... But this is the information:

PYTHONPATH and LD_LIBRARY_PATH are empty. PATH has this value:


Additional info:

$ guix package --search-paths
export PATH="/home/anonimo/.guix-profile/bin"

Are you able to work around the problem with:

  guix environment --ad-hoc weechat --pure -- weechat


WeeChat starts correctly if I run it that way.

Luis Felipe López Acevedo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]