[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setting up eth-multiplexer in QEMU

From: Sergiu Ivanov
Subject: Re: Setting up eth-multiplexer in QEMU
Date: Mon, 29 Jun 2009 22:21:22 +0300
User-agent: Mutt/1.5.18 (2008-05-17)


On Mon, Jun 29, 2009 at 08:55:51AM +0800, Zheng Da wrote:
> On Sun, Jun 28, 2009 at 9:56 PM, Sergiu
> Ivanov<unlimitedscolobb@gmail.com> wrote:
> > This makes me suspect that eth-multiplexer is not the troublesome
> > component we are looking for. Do you share this opinion or do you
> > still insist on my trying to deprive eth-multiplexer of the
> > functionality of setting the device in promiscuous mode?
> Since the modified pfinet cannot work either, the problem should be in pfinet.
> I wonder what modification in pfinet can cause the problem.

I've found out a stunning thing (for me) today: I checked out a fresh
Hurd from CVS in the following way:

 $ cvs -z3 -d:pserver:anonymous@cvs.savannah.gnu.org:/sources/hurd co hurd

Then I created build/ , went there, configured and ran make
pfinet. The executable file pfinet I got as a result behaves in the
*same* way as the modified pfinet + devnode! That is, things work a
little bit slowly, and wget stalls having downloaded the same 2,576
bytes :-(

I wonder whether this can be caused by the fact that I'm using the CVS
repository... I tried to find Hurd git repository, but I only ran over
some links on Savannah which pointed to a repository having only a
README file. Could somebody point out where I could find the correct
git repository?

Also, I didn't apply Debian patches, but I'm not sure whether they
could be the cause... I didn't apply them because, apparently,
something is different in the main Hurd branch and Zheng's branch,
because exactly the series of patches which worked in Zheng's branch
failed in the source tree I got by means of the command mentioned


reply via email to

[Prev in Thread] Current Thread [Next in Thread]