[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setting up eth-multiplexer in QEMU

From: Thomas Schwinge
Subject: Re: Setting up eth-multiplexer in QEMU
Date: Mon, 29 Jun 2009 22:18:35 +0200
User-agent: Mutt/1.5.11


On Mon, Jun 29, 2009 at 10:21:22PM +0300, Sergiu Ivanov wrote:
> On Mon, Jun 29, 2009 at 08:55:51AM +0800, Zheng Da wrote:
> > On Sun, Jun 28, 2009 at 9:56 PM, Sergiu
> > Ivanov<unlimitedscolobb@gmail.com> wrote:
> > > This makes me suspect that eth-multiplexer is not the troublesome
> > > component we are looking for. Do you share this opinion or do you
> > > still insist on my trying to deprive eth-multiplexer of the
> > > functionality of setting the device in promiscuous mode?
> > 
> > Since the modified pfinet cannot work either, the problem should be in 
> > pfinet.
> > I wonder what modification in pfinet can cause the problem.
> I've found out a stunning thing (for me) today: I checked out a fresh
> Hurd from CVS in the following way:
>  $ cvs -z3 -d:pserver:anonymous@cvs.savannah.gnu.org:/sources/hurd co hurd
> Then I created build/ , went there, configured and ran make
> pfinet. The executable file pfinet I got as a result behaves in the
> *same* way as the modified pfinet + devnode! That is, things work a
> little bit slowly, and wget stalls having downloaded the same 2,576
> bytes :-(

May I ask, and I should have realized this earlier! -- in the context of
our IRC discussion one or two weeks ago when we told you to update your
system -- which version of GCC did you use to build pfinet?
<http://savannah.gnu.org/bugs/?23551> -- did you use GCC 4.3?  If yes,
then sorry for the wasted time!, and hooray for having (hopefully)
resolved this mystery.

> I wonder whether this can be caused by the fact that I'm using the CVS
> repository... I tried to find Hurd git repository, but I only ran over
> some links on Savannah which pointed to a repository having only a
> README file.

That one, and a lot of other (web) pages, should be updated to reflect
that we moved to Git.

> Could somebody point out where I could find the correct
> git repository?

<http://www.gnu.org/software/hurd/rules/source_repositories.html>: ``Git
repositories on Savannah, see <http://git.savannah.gnu.org/cgit/> (search
for hurd).'' -- <http://git.savannah.gnu.org/cgit/hurd/> is a more
suitable link, which I'll add to that page.

> Also, I didn't apply Debian patches, but I'm not sure whether they
> could be the cause... I didn't apply them because, apparently,
> something is different in the main Hurd branch and Zheng's branch,

Probably it's been some time since the HEAD branch has last been merged
into Zheng's branch.  (This will improve as soon as I've transitioned
these working-branches to Git.)

> because exactly the series of patches which worked in Zheng's branch
> failed in the source tree I got by means of the command mentioned
> above.

Relevant (depending on your version of glibc) are (very likely) need the
in6_addr.patch, to avoid a build failure, which is in HEAD (and Git
master, but not in Zheng's branch, I guess).  Then there is the DHCP
patch for pfinet, which is not important for your usage, and that's it:
nothing else is relevant for pfinet.


Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]