[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] PCI-DAS4020/12 problem roundup

From: Steven Franke
Subject: Re: [Discuss-gnuradio] PCI-DAS4020/12 problem roundup
Date: Fri, 20 Jun 2003 11:06:41 -0500

I tried Sergio's patch also. I believe that the reason that the graphs displayed zero signal is because Sergio changed the ADC channel from 3 to 0 in his code (or vice versa, I forget!). His approach does prevent the lockups, provided one is willing to let the program fall through the main loop eventually so that it calls the destructor. It would be even more useful if someone can provide a clue for incorporating his fix so that the desructor is called after hitting the "Quit" button on the displayed GUI panel.

In a correspondence with Eric, we noticed that when I compiled the 0.7 driver I received more compilation errors than he does. This is apparently because I used the prerelease version of gcc 3.3 in the SuSE 8.2 distribution. Perhaps this is a clue?

Steve Franke

On Friday, June 20, 2003, at 10:47  AM, Ricky Hussmann wrote:

Here's my update on the issues with 4020 board PC lockup.

Summary of the problem:

I and apparently other users on the list are having trouble running any example program that uses the MC4020 multiple times. The first time running an example using the MC4020 after startup works flawlessly. However, after that example is closed and any other example run that uses the MC4020 the
machine completely locks up.

Attempts at solutions:

First, I am working with the latest (0.7) driver for the mc4020.

I have applied Sergio's patch and tried recompiling GNU Radio. In his modified
version of GrMC4020.h the line

#include <mc4020.h>

is missing, so if you had problems compiling try inserting the above line and recompiling. After compiling his version of adc_fft.cc and testing it I WAS able to run the program multiple times. However, the graphs displayed a dead zero signal even though I was inputting a sine wave into the 4020. Also, Sergio simply uses a countdown from 1,000 to bypass exit from the loop and properly call the destructor for the GrSourceMC4020 class. This causes the
program to terminate shortly after it started.

My thoughts:

Just from the nature of the problem, I believe this is an issue with not correctly deallocating resources the device is using. I'm lead to believe
this because:

1.) The machine locks up only after an example program has been run and closed
and another has been executed.

2.) Sergio's call to the destructor allowed the program to be run multiple
times, even though no data was displayed on the graphs in the adc3_fft

I haven't delved deeply into GNU Radio's core and I'm not sure I'd understand it if I did, but I'm willing to provide whatever assistance is necessary to solve this problem (it's really a pain when trying to work with the 4020

My hardware configuration:

I'm using a Dell Dimension XPS T750r that appears to be using the Intel 440
BX/ZX/DX chipset. It is using the Intel PIIX4 Ultra 33 chipset for IDE
control. It has a 750 MHz Intel P3 processor. I'm running Slackware 9.0 with
the 2.4.20 series kernel stock from install.

Hope this can help,
Ricky Hussmann

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]