[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] usrper fails in usb_claim_interface

From: James Cooley
Subject: Re: [Discuss-gnuradio] usrper fails in usb_claim_interface
Date: Wed, 27 Apr 2005 21:36:26 -0400
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050317)

I am now seeing something like this one crop up, very annoying.

Basically, I'm running in RX mode for a while. I stop running. I may unplug usrp, plug it in. Then:

usrp: found usrp rev2
usrp_open_interface:usb_claim_interface: failed interface 2
could not claim interface 2: No such file or directory
usrp_basic_rx: can't open rx interface
Traceback (most recent call last):

<snip python traceback stuff>

I've tried many things to try to work around it. Sometimes I've tried to reboot, but that doesn't *always* work. I should say, I'm running a few things off of USB... an external hard drive, the usrp, and a DB9 serial adapter thing.

Can it be solved in the same way, rmmod usbtest? Or is there something else at work?


Matt Ettus wrote:

Quoting Larry Doolittle <address@hidden>:

On Tue, Apr 05, 2005 at 02:18:19PM -0700, Eric Blossom wrote:
On Tue, Apr 05, 2005 at 12:03:00PM -0700, Larry Doolittle wrote:
I have an Avnet Virtex 4 evaluation board, intended for
projects similar in concept to GNU Radio.  It uses the
same CY7C68013 chip as USRP.

I used USRP as a software reference design, and started
splicing in some code of my own. [chop]
2005-04-05 11:20:16.264596500 <6>usbtest 5-1:1.0: FX2 device
2005-04-05 11:20:16.264640500 <6>usbtest 5-1:1.0: high speed {control
bulk-in bulk-out} tests (+alt)

You have the usbtest module loaded.
rmmod it.
Eric is right, when I rmmod usbtest this problem goes away.
Someplace in the bowels of debian sid this module is configured
to reload every time I plug in the device, and I then have to
rmmod it again by hand.  "find /etc -type f | xargs grep usbtest"
didn't find the magic.

Once you reprogram the EEPROM to something other than the default device,
usbtest stops loading itself.


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]