[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio via MacPorts Updated

From: Alexandru Csete
Subject: Re: [Discuss-gnuradio] GNU Radio via MacPorts Updated
Date: Thu, 9 Sep 2010 23:26:21 +0200

On Tue, Sep 7, 2010 at 4:28 PM, Michael Dickens <address@hidden> wrote:
I've updated the GNU Radio install via MacPorts to 3.3.0.

For those OSX users out there who are using GNU Radio and MacPorts, could you give this a shot & see if it works for you?  If you do install them for testing purposes & want to use a non-MacPorts GIT install for your actual work, make sure to deactivate / uninstall those from MacPorts -- usually there is no conflict between multiple GNU Radio installs, but it's just safer this way.

If you have thoughts or comments on the MacPorts install of GNU Radio on OSX, I'd love to hear from you. - MLD

Hi Michael,

Thank you for this new update. I have now installed it and it seems to be working fine.
Some notes:

(1) I didn't have macports installed so it was a clean installation. After installing the macports app I just ran "sudo port install gnuradio" and let it run overnight.

(2) After installation I had to add
export PYTHONPATH=$PYTHONPATH:/opt/local/lib/python2.6/site-packages
to my .profile file. I guess it is normal, but I was a bit surprised since macports has already modified this file to set up the PATH and also other environment variables like pkg-config seem to be set up correctly. Anyway, after doing this I could execute the audio examples :)

(3) gnuradio-companion couldn't find "pygtk" and to make it work I also had to add
to my PYTHONPATH. So, gnuradio-companion is now working and I could execute simple wxgui script with audio, FFT scope and waterfall :)

(4) Not sure about the Qt stuff... In the source tree I tried to execute the pyqt_example.py script and got:
Traceback (most recent call last):
  File "pyqt_example.py", line 4, in <module>
    from gnuradio.qtgui import qtgui
  File "/opt/local/lib/python2.6/site-packages/gnuradio/qtgui/qtgui.py", line 24, in <module>
    _qtgui = swig_import_helper()
  File "/opt/local/lib/python2.6/site-packages/gnuradio/qtgui/qtgui.py", line 20, in swig_import_helper
    _mod = imp.load_module('_qtgui', fp, pathname, description)
ImportError: dlopen(/opt/local/lib/python2.6/site-packages/gnuradio/qtgui/_qtgui.so, 2): Library not loaded: libqwtplot3d.0.dylib
  Referenced from: /opt/local/lib/python2.6/site-packages/gnuradio/qtgui/_qtgui.so
  Reason: image not found

I found the libqwtplot3d.0.dylib in /opt/local/lib but I get the same error even after adding it to LD_LIBRARY_PATH in the .profile file

Next I will try my USRP. On Ubuntu Linux we have to set up udev to recognize the USRP, is there something similar that has to be done on the mac?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]