[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] gnuradio make error

From: Don Ward
Subject: Re: [Discuss-gnuradio] gnuradio make error
Date: Sun, 19 Dec 2010 21:42:25 -0500

alirazib wrote:

Thanks for your feedback. I have followed your suggestions to install a new cygwin with gcc 3.4.4 for gnuradio. Still WxPython could not be built. Step
9 ($ python setup.py build_ext --inplace WXPORT=msw COMPILER=cygwin
=0 BUILD_GIZMOS=0 UNICODE=0) gives the following error:

WARNING: WXWIN not set in environment. Assuming '..'
   3 [main] python 4516 C:\cygwin\bin\python.exe: *** fatal error -
unable to
remap \\?\C:\cygwin\lib\python2.6\lib-dynload\time.dll to same address as
t: 0x260000 != 0x340000
Stack trace:
Frame     Function  Args
002296E8  6102749B  (002296E8, 00000000, 00000000, 00000000)
002299D8  6102749B  (61177B80, 00008000, 00000000, 61179977)
0022AA08  61004AFB  (611A136C, 6123F284, 00260000, 00340000)
End of stack trace
     3 [main] python 268 fork: child 4516 - died waiting for dll loading,
errno 11
error: Resource temporarily unavailable

This is a Cygwin (not wxPython) problem. Try a Google search on "unable to remap". (I can't tell you how to fix it from personal experience since I haven't seen the problem myself.)

then I tried to make gnuradio, but with the same error:

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../../../..
-I/usr/local/include -I
clude -g -O2 -Wall -Woverloaded-virtual -MT qa_pmt_unv.lo -MD -MP -MF
mt_unv.Tpo -c qa_pmt_unv.cc  -DDLL_EXPORT -DPIC -o .libs/qa_pmt_unv.o
mv -f .deps/qa_pmt_unv.Tpo .deps/qa_pmt_unv.Plo
/bin/sh ../../../../libtool --tag=CXX   --mode=link g++ -g -O2  -Wall
ed-virtual  -no-undefined -avoid version  -o libpmt-qa.la  qa_pmt.lo
s.lo qa_pmt_unv.lo libpmt.la -lcppunit -ldl   -lstdc++
/usr/bin/grep: /usr/lib/gcc/i686-pc-cygwin/4.3.2/libstdc++.la: No such file
or directory

This is because you are using cppunit 1.12.1-1. If you use cppunit 1.12.0-1 you won't have this problem. You may need to start over on the GNU Radio installation after going back to 1.12.0-1.

Hope this helps,

-- Don W.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]