[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio Using MacPorts

From: Arturo Rinaldi
Subject: Re: [Discuss-gnuradio] GNU Radio Using MacPorts
Date: Tue, 27 Nov 2012 02:57:07 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Thunderbird/17.0

Nella citazione in data Tue Nov 27 00:36:33 2012, Michael Dickens ha scritto:

On Nov 26, 2012, at 5:30 PM, Arturo Rinaldi <address@hidden> wrote:
I smoothly installed the port version with

sudo port install gnuradio +docs +grc +python27 +qtgui +wxgui +uhd +volk 
+wavelet +jack +portaudio +swig +sdl configure.compiler=llvm-gcc-4.2

performing a full installation.


Now my question is, is there a way to use the GL sinks (scopesink, fftsink and 
so on) ? Every time i run a flow graph containing one of these elements, i get 
a OpenGL error and its pyton binding....any hint to solve this issue ?

Can you post the console error message so that we can see what's going on, as 
well as what you were trying to do when you got the error? - MLD

Ok let's do just a simple flow graph. Here's the screenshot :


I'm trying to display a simple cosine waveform in a WXGUI Scopesink. This is the error I get when I run the flow graph :

Traceback (most recent call last):
File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gnuradio/wxgui/plotter/plotter_base.py", line 187, in _on_paint
   for fcn in self._draw_fcns: fcn[1]()
File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gnuradio/wxgui/plotter/plotter_base.py", line 58, in draw
   GL.glNewList(self._grid_compiled_list_id, GL.GL_COMPILE)
ctypes.ArgumentError: argument 1: <type 'exceptions.TypeError'>: wrong type

I get the controls part but not the plotting part of the sink :


No issues apparently with QT SINKS.

Regards, Arturo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]