[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio Using MacPorts

From: Michael Dickens
Subject: Re: [Discuss-gnuradio] GNU Radio Using MacPorts
Date: Wed, 28 Nov 2012 20:24:03 -0500

Hi Arturo - Can you load up the GRC example provided by GR: 
gnuradio/examples/grc/simple/variable_config.grc ?  This file works just fine 
for me, no GL issues or anything, and it looks about the same as your figure 
(or, maybe I'm doing something wrong?).  I'm running from the latest GIT master 
(as installed by MacPorts "gnuradio-devel +full"; just updated this morning!).  
If this gives you the same error, then either email me off-list and we can work 
on resolving it; or, create a ticket in MacPorts and assign me as the owner and 
I'll work with you there. - MLD

On Nov 26, 2012, at 8:57 PM, Arturo Rinaldi <address@hidden> wrote:
> Ok let's do just a simple flow graph. Here's the screenshot :
> http://img594.imageshack.us/img594/5670/testnz.png
> I'm trying to display a simple cosine waveform in a WXGUI Scopesink. This is 
> the error I get when I run the flow graph :
> Traceback (most recent call last):
> File 
> "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gnuradio/wxgui/plotter/plotter_base.py",
>  line 187, in _on_paint
>   for fcn in self._draw_fcns: fcn[1]()
> File 
> "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/gnuradio/wxgui/plotter/plotter_base.py",
>  line 58, in draw
>   GL.glNewList(self._grid_compiled_list_id, GL.GL_COMPILE)
> ctypes.ArgumentError: argument 1: <type 'exceptions.TypeError'>: wrong type
> I get the controls part but not the plotting part of the sink :
> http://img842.imageshack.us/img842/2728/test2xm.png
> No issues apparently with QT SINKS.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]