[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] WX Gui Widget Error

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] WX Gui Widget Error
Date: Fri, 1 Mar 2013 09:09:11 -0500

On Fri, Mar 1, 2013 at 8:42 AM, B Hun <address@hidden> wrote:
> Mihai Chermaneanu <chrmihai <at> gmail.com> writes:
> ....(*args, **kwargs)ValueError: in method 'BookCtrlBase_SetSelection',
> expected argument 2 of type 'size_t'
> I get the same error.  I just installed gnuradio for windows as per the
> instructions on the ettus website
> (http://code.ettus.com/redmine/ettus/projects/uhd/wiki/GNURadio_Windows).
> When I run the cvsd_sweep.grc example I get the same error:
> ...    return _controls_.BookCtrlBase_SetSelection(*args, **kwargs)
> ValueError: in method 'BookCtrlBase_SetSelection', expected argument 2 of
> type 'size_t'.  I hear the sweet tone but all the plots a re messed up and do
> not display any data.
> I uninstalled and reinstalled exverything but still get the same error.  I
> even tried going back to versions of each item, one at a time, that a coworker
> had working last year but I still get the same error.
> I also ran the dial_tone.grc example and I hear the tone and the gui seems to
> work but I get this error:
> ...\AppData\Roaming\.gnuradio\prefs\gr_vmcircbuf_default_factoryC:\app
> s\gnuradio\lib\site-packages\gnuradio\grc\gui\Dialogs.py:36: GtkWarning:
> gtk_tex
> t_buffer_emit_insert: assertion `g_utf8_validate (text, len, NULL)' failed
>   self.insert = lambda line: text_buffer.insert(text_buffer.get_end_iter(),
> line
> )
> : Invalid argument
> ÉÖI?°êI?\bhehn\AppData\Roaming\.gnuradio\prefs\gr_vmcircbuf_default_factory:
> Inv
> alid argument
> Thanks for any help,
> B

What version of wxPython are you running? They've released a 2.9 which
might have an API change causing this problem. If you are using 2.9,
try going back to a 2.8 release and see if that help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]