[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] CentOS pymbombs install

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] CentOS pymbombs install
Date: Tue, 6 Jan 2015 18:46:41 -0500

On Tue, Jan 6, 2015 at 4:43 PM, Richard Bell <address@hidden> wrote:
Thanks, I did try 'sudo yum clean all'. I've tried a lot of things, this is the fifth or 6th time I've tried installing gnuradio on this CentOS laptop.

If I follow the link to the ftp site its looking for the tarball in, which is here:


There seems to be no more tarball with a 'patched' modifier at the end of it. Will gnuradio be ok if I install pygobject-2.27.91.tar.gz, or a newer version perhaps? I just don't know enough about these packages and the inner workings of gnuradio.



Is this CentOS 7? If so, you're probably not going to get very far. I've yet to figure out how to cleanly get GNU Radio to install on that OS. It works great on CentOS 5 and 6, but they've changed a lot with 7, specifically in removing (as far as I can tell) wxPython support.


On Tue, Jan 6, 2015 at 1:01 PM, Marcus D. Leech <address@hidden> wrote:
I've been running into difficulties using pybombs on my CentOS machine. I was told many users in the community use CentOS successfully so I'm looking to you for guidance. I am following the pybombs install instructions here:


The uhd install completes without any issue. Pybombs identifies missing dependencies, installs them all and then installs uhd. Great.

When I begin the gnuradio install, it identifies missing dependencies, begins installing them, but whenever it gets to pygobject, I run into the following issue:

--2015-01-06 12:24:07--  http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz
Resolving ftp.gnome.org...,,, ...
Connecting to ftp.gnome.org||:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://gensho.acc.umu.se/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz [following]
--2015-01-06 12:24:07--  http://gensho.acc.umu.se/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz
Resolving gensho.acc.umu.se..., 2001:6b0:e:2018::176
Connecting to gensho.acc.umu.se||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-01-06 12:24:07 ERROR 404: Not Found.

This happened yesterday and it's happening today. Can someone help me through this please.


This really has nothing to do with PyBombs or Gnu Radio.

Your distributions Repo is pointing you at a mirror that doesn't have the file that it should have.  Not sure if there's a way on Centos to flush
  things so that it tries a different mirror.


sudo yum clean all

And try again?

Pybombs just uses your native package-management framework to fetch and install "stuff".  It doesn't know much about the internals of that, but
  relies on your systems package-management system to be "sane".  In this case, some part of it is "insane", and there's nothing that PyBombs
  can do about that.

Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]