[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] CentOS pymbombs install

From: Ralph A. Schmid, dk5ras
Subject: Re: [Discuss-gnuradio] CentOS pymbombs install
Date: Wed, 7 Jan 2015 09:33:31 +0100

You did not forget a „sudo ldconfig“? Sometimes the simple things… J




From: address@hidden [mailto:address@hidden On Behalf Of Richard Bell
Sent: Wednesday, January 7, 2015 2:10 AM
To: Tom Rondeau
Cc: address@hidden
Subject: Re: [Discuss-gnuradio] CentOS pymbombs install


Well, completed a sudo make install for pygobject-2.27.91 with no errors. (I ignored the fail of make test and pushed on to sudo make install)

Unfortunately now, and this is what I feared, when I run ./pybombs install gnuradio, it can't tell that pygobjects is already installed. I know I can tell pybombs to assume pygobjects is installed, but I'm scared to death of what will happen later when I try and open gnuradio I get a big error message.



On Tue, Jan 6, 2015 at 4:31 PM, Richard Bell <address@hidden> wrote:

This link fixed the previous error, at least getting me through 'make':


but when I run 'make check', I have the following error:

TEST_FILES="test_everything.py test_gi.py test_gdbus.py test_overrides.py" PYTHONPATH=..:../tests:${PYTHONPATH:+:$PYTHONPATH} LD_LIBRARY_PATH=./.libs:$LD_LIBRARY_PATH GI_TYPELIB_PATH=.:$GI_TYPELIB_PATH XDG_DATA_DIRS=$XDG_DATA_DIRS:/usr/share /usr/bin/dbus-launch  /usr/bin/python ./runtests.py
Traceback (most recent call last):
  File "./runtests.py", line 24, in <module>
    suite = loader.loadTestsFromNames(names)
  File "/usr/lib64/python2.6/unittest.py", line 612, in loadTestsFromNames
    suites = [self.loadTestsFromName(name, module) for name in names]
  File "/usr/lib64/python2.6/unittest.py", line 575, in loadTestsFromName
    module = __import__('.'.join(parts_copy))
  File "/home/tsvcis/Documents/pybombs/src/pygobject-2.27.91/tests/test_gdbus.py", line 11, in <module>
    from gi.repository import Gio
  File "../gi/importer.py", line 76, in load_module
  File "../gi/module.py", line 242, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "../gi/overrides/Gio.py", line 98, in <module>
    Settings = override(Settings)
  File "../gi/overrides/__init__.py", line 63, in override
  File "../gi/overrides/__init__.py", line 38, in register
    self[override_class] = override_class
  File "../gi/overrides/__init__.py", line 28, in __setitem__
    assert g_type != gobject.TYPE_NONE
make[2]: *** [check-local] Error 1
make[2]: Leaving directory `/home/tsvcis/Documents/pybombs/src/pygobject-2.27.91/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/home/tsvcis/Documents/pybombs/src/pygobject-2.27.91/tests'
make: *** [check-recursive] Error 1

Still digging...


On Tue, Jan 6, 2015 at 3:51 PM, Richard Bell <address@hidden> wrote:

Sorry I forgot to mention the version, it is CentOS 6.6.

pygobject is my problem. I'm still unable to get it installed correctly. I downloaded both version 2.27.91 and 2.28 from the ftp site I posted and tried a manual install, but they fail with the following error:

In file included from /usr/include/python2.6/Python.h:125,
                 from ../glib/pyglib.h:25,
                 from gobjectmodule.c:28:
/usr/include/python2.6/modsupport.h:136: error: expected ')' before 'uid'
/usr/include/python2.6/modsupport.h:137: error: expected ')' before 'gid'
/usr/include/python2.6/modsupport.h:139: error: expected declaration specifiers or '...' before 'uid_t'
/usr/include/python2.6/modsupport.h:140: error: expected declaration specifiers or '...' before 'gid_t'
make[2]: *** [_gobject_la-gobjectmodule.lo] Error 1
make[2]: Leaving directory `/home/tsvcis/Documents/pybombs/src/pygobject-2.27.91/gobject'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tsvcis/Documents/pybombs/src/pygobject-2.27.91'
make: *** [all] Error 2

I'm posting questions on the CentOS forums as well, but no response yet. Tom, have you run into this problem on a CentOS6 system? If not, I wonder why mine is different...



On Tue, Jan 6, 2015 at 3:46 PM, Tom Rondeau <address@hidden> wrote:

On Tue, Jan 6, 2015 at 4:43 PM, Richard Bell <address@hidden> wrote:

Thanks, I did try 'sudo yum clean all'. I've tried a lot of things, this is the fifth or 6th time I've tried installing gnuradio on this CentOS laptop.


If I follow the link to the ftp site its looking for the tarball in, which is here:


There seems to be no more tarball with a 'patched' modifier at the end of it. Will gnuradio be ok if I install pygobject-2.27.91.tar.gz, or a newer version perhaps? I just don't know enough about these packages and the inner workings of gnuradio.





Is this CentOS 7? If so, you're probably not going to get very far. I've yet to figure out how to cleanly get GNU Radio to install on that OS. It works great on CentOS 5 and 6, but they've changed a lot with 7, specifically in removing (as far as I can tell) wxPython support.






On Tue, Jan 6, 2015 at 1:01 PM, Marcus D. Leech <address@hidden> wrote:

I've been running into difficulties using pybombs on my CentOS machine. I was told many users in the community use CentOS successfully so I'm looking to you for guidance. I am following the pybombs install instructions here:


The uhd install completes without any issue. Pybombs identifies missing dependencies, installs them all and then installs uhd. Great.

When I begin the gnuradio install, it identifies missing dependencies, begins installing them, but whenever it gets to pygobject, I run into the following issue:

--2015-01-06 12:24:07--  http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz
Resolving ftp.gnome.org...,,, ...
Connecting to ftp.gnome.org||:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://gensho.acc.umu.se/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz [following]
--2015-01-06 12:24:07--  http://gensho.acc.umu.se/pub/GNOME/sources/pygobject/2.27/pygobject-2.27.91.patched.tar.gz
Resolving gensho.acc.umu.se..., 2001:6b0:e:2018::176
Connecting to gensho.acc.umu.se||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-01-06 12:24:07 ERROR 404: Not Found.

This happened yesterday and it's happening today. Can someone help me through this please.




This really has nothing to do with PyBombs or Gnu Radio.

Your distributions Repo is pointing you at a mirror that doesn't have the file that it should have.  Not sure if there's a way on Centos to flush
  things so that it tries a different mirror.


sudo yum clean all

And try again?

Pybombs just uses your native package-management framework to fetch and install "stuff".  It doesn't know much about the internals of that, but
  relies on your systems package-management system to be "sane".  In this case, some part of it is "insane", and there's nothing that PyBombs
  can do about that.

Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium


Discuss-gnuradio mailing list


Discuss-gnuradio mailing list





reply via email to

[Prev in Thread] Current Thread [Next in Thread]