[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Issues Installing From Source

From: Peter Witkowski
Subject: [Discuss-gnuradio] Issues Installing From Source
Date: Wed, 4 Mar 2015 10:40:41 -0500


In the past, I've always used the build-gnuradio script to install everything with great success.  This ensures that I have all the latest versions of both GNU Radio and UHD.

However, I recently got a new machine and installed Ubuntu 14.04 on it (I haven't had any issues with 14.04 before).  I updated the OS to the latest version and then tried using build-gnuradio.  Immediately I started having issues.  First, the script was unable to install git, cmake, and other dependencies.  However, I was manually able to do a "sudo apt-get" on all of these packages and at least get to the point where the script tries to install UHD.

Now I've run into a strange issue where "make install" for UHD appears to put all the .hpp files in the right place, but the script fails because it can't find the uhd_find_devices command.  I've tried to manually make install UHD with the same effects.  It tells me that all the .hpp files are in the correct directory, but I still cannot locate the uhd_find_devices command.  Note that running build-gnuradio with the verbose flag set didn't throw any errors that I can see.

Has anyone experienced similar issues?  Does the simple "sudo apt-get install gnuradio" command install the latest versions of UHD and GNU Radio?  I am also leaning towards trying a PyBOMBS based install.  That said, I don't think I'm doing anything differently this time around and I've always had good luck with using build-gnuradio.

Thanks in advance for the help.

Peter Witkowski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]