[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Issues Installing From Source

From: Johnathan Corgan
Subject: Re: [Discuss-gnuradio] Issues Installing From Source
Date: Thu, 5 Mar 2015 14:41:32 -0800

This might be related to an issue I ran into with 14.04.2 when making the Live SDR images based on that.

If you install 14.04.2 from CD, then do:

$ apt-get install libgl1-mesa-dev-lts-utopic mesa-common-dev-lts-utopic

...then try build-gnuradio, does it work?

On Thu, Mar 5, 2015 at 2:01 PM, Peter Witkowski <address@hidden> wrote:

My hesitation to use PyBOMBS was only a function of the fact that I've have had really good success using the build-gnuradio script in the past.  I've deployed GNU Radio and UHD using Marcus's awesome script several times and never had an issue.

Also, I can confirm that the problem (at least on my end) is tied to Ubuntu 14.4.2 (released a few weeks ago).  When I did a clean install of 14.4.1, the script ran just fine.  The problem can be duplicated by installing 14.4.2 (using the latest download from the Ubuntu site) and then attempting to follow the install instructions.  I detailed the symptoms I was experiencing in my original e-mail.  Note that even with -v enabled, no errors were printed.  It looked like it was installing all the prerequisites, but then later said it couldn't find git, cmake, etc.

The really weird thing (and this makes me think that Ubuntu might have something up with their current install ISO) is that if I install 14.4.1 from CD and then patch it to the latest version, I can still run build-gnuradio just fine.

On Thu, Mar 5, 2015 at 11:42 AM, Richard Bell <address@hidden> wrote:
Are you guys avoiding pybombs for a reason, or do you just not feel comfortable with it? If you're aware of pybombs and have a reason for avoiding it, then stop reading here.

Pybombs works really well on Ubuntu 14.04. I've installed UHD + GnuRadio on multiple machines without a problem. Using it to install all dependencies and UHD and GnuRadio is as simple as the following few lines of code:

1) cd to the directory of your choice
2) git clone https://github.com/pybombs/pybombs.git && cd pybombs
3) ./pybombs install gnuradio (this will install all dependencies needed for gnuradio including uhd)
4) ./pybombs env (creates an environment variables file for you)
5) add this to your .bashrc or .bash_aliases file, whichever you use: source /<path_to_step1_directory>/target/setup_env.sh
6) start her up: gnuradio-companion

That's all there is to it.

Hope that helps,

On Thu, Mar 5, 2015 at 8:07 AM, <address@hidden> wrote:

So, if I could get an actual, detailed, error-report when build-gnuradio fails, I can look into fixing it.

It has worked well on Ubuntu 14.04 since 14.04 was released, but it may be the case that some system update changed something that buggered up an assumption that build-gnuradio is making.  But without a complete log of a "-v" run,
 I have no way of figuring out what's going wrong.




On 2015-03-05 03:15, krishnachand leela wrote:

Hello Peter

I had installed yesterday on my laptop with Ubuntu 14.04
I tried using WGET......... but I got the similar problems like you regarding the git..
So, I have installed it from source and haven't got any problem.

You can follow these steps for installing it from source

Thee are two methods to install but I preferred to install it from source

1)Install Dependencies:

//Copy the below commands and paste it in terminal(all at a single time)//
sudo apt-get -y install libfontconfig1-dev libxrender-dev libpulse-dev swig g++ automake autoconf libtool python-dev libfftw3-dev libcppunit-dev libboost-all-dev libusb-dev fort77 sdcc sdcc-libraries libsdl1.2-dev python-wxgtk2.8 git-core guile-1.8-dev libqt4-dev python-numpy ccache python-opengl libgsl0-dev python-cheetah python-lxml doxygen qt4-dev-tools libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4

2)Install prerequesties for UHD
sudo apt-get install libboost-all-dev libusb-1.0-0-dev python-cheetah doxygen python-docutils cmake

3)Installing UHD from git
git clone git://github.com/EttusResearch/uhd.git

4)Cmake for UHD
//Follow these commands step by stp//
cd uhd/host/
mkdir build
cd build/
cmake ../

5) //Check the output of above one regarding the disabled components. Based upon our requirement we should select the USRP.//
For example: cmake -DENABLE_USRP_E_UTILS=ON -DENABLE_E100=ON ../


7)Installing UHD and setting library path
make test(check whether it shows 100% or not)
sudo make install
sudo gedit .bashrc

8)//Add this after HISTCONTROL=ignoredups:ignorespace//

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:usr/local/lib

//Save it and close//

9)git clone http://gnuradio.org/git/gnuradio.git
///This will take some time Can take even more than 2hrs////

cd gnuradio/
mkdir build/
cd build/
cmake ../
make test
sudo make install
cd /usr/local/lib/python2.6/dist-packages/
//copy the path//
sudo gedit .bashrc

10) In 8th step we have added a path, after that one add

export PYTHONPATH=$PYTHONPATH:/usr/local/lib/python2.7/dist-packages

//if u prefer python 3.0 then u can add 3.0//
//Save it and close//

11)sudo ldconfig

12)sudo apt-get install gnuradio-companion

1)If you get any error related to dpkg then run the command as suggested in the error.

2)Installation can take around 2hours and it depends upon the speed of your internet
I hope it could help you


On Thu, Mar 5, 2015 at 4:02 PM, Ralph A. Schmid, dk5ras <address@hidden> wrote:
I am afraid I did not document this, but I ran into similar issues with the
script and Kubuntu 14.04. However doing it all by hand, resolving
dependencies, load uhd and gnuradio sources, compile the stuff, installing
udev rules, installing the gnuradio icons by hand and such, this all was not
a big deal, and in some cases I simply read the script as a manual how to do

Pybombs is something I could not become friends with yet. For many people it
seems to work, for me all attempts were disastreous.


> -----Original Message-----
> From: discuss-gnuradio-bounces+ralph=address@hidden
> [mailto:discuss-gnuradio-bounces+ralph=address@hidden] On Behalf Of
> Marcus D. Leech
> Sent: Wednesday, March 4, 2015 5:43 PM
> To: address@hidden
> Subject: Re: [Discuss-gnuradio] Issues Installing From Source
> On 03/04/2015 10:40 AM, Peter Witkowski wrote:
> > Hello,
> >
> > In the past, I've always used the build-gnuradio script to install
> > everything with great success.  This ensures that I have all the
> > latest versions of both GNU Radio and UHD.
> >
> > However, I recently got a new machine and installed Ubuntu 14.04 on it
> > (I haven't had any issues with 14.04 before). I updated the OS to the
> > latest version and then tried using build-gnuradio.  Immediately I
> > started having issues.  First, the script was unable to install git,
> > cmake, and other dependencies.  However, I was manually able to do a
> > "sudo apt-get" on all of these packages and at least get to the point
> > where the script tries to install UHD.
> This is the first I've heard of it having problems doing the pre-req
installs.  If
> you run build-gnuradio with -v, you get more details about why.
>    If the underlying OS tooling is falling over, there's very little that
> gnuradio can do about it.  It has as much troubleshoot-and-repair
>    ability as a moribund gnat.
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Peter Witkowski

Discuss-gnuradio mailing list

Johnathan Corgan
Corgan Labs - SDR Training and Development Services

reply via email to

[Prev in Thread] Current Thread [Next in Thread]