[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNURadio 3.8 - Ubuntu 20.04.01 LTS and Adalm-Pluto

From: Christophe Seguinot
Subject: Re: GNURadio 3.8 - Ubuntu 20.04.01 LTS and Adalm-Pluto
Date: Thu, 3 Sep 2020 17:22:16 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0


I experienced a similar issue when using gr-osmosdr and gr-limesdr too so my experience could help for this problem (I did not use Adalm-Pluto)

I installed gnuradio 3.8.1 (bad idea since Synaptic always ask to update to 3.8.2) OR 3.8.2 from http://ppa.launchpad.net/gnuradio/gnuradio-releases/ubuntu; both version led to the same issue

In my case I solved the issue by unsinstalling all gr-xxx package, (re)install GR 3.8.2, remove all remaining 3.8.1 or 3.8.0 libgnuradio libraries (if 3.8.2 is installed), and then compile and install all gr-xxx from source codes


On 03/09/2020 16:43, Freddy Van Ingelgom wrote:
Hello everyone,
This is my first post in this list.
I used gnuradio for some time yet, but recently I saved a acer Travelmate from Win7 and installed Ubuntu 20.04. I Installed gnuradio 3.8. I installed also gr-iio, libiio and libad9361-iio.
When I try to run a flowchart with plutosdr source, I have the message "ModuleNotFoundError: No module named 'iio'"
I found several "solutions" on the net, but not one that worked for me.
Anyone else had this problem and solved it?
Thanks for your help!
Freddy, ON7VQ

reply via email to

[Prev in Thread] Current Thread [Next in Thread]