discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ANN: GNUstepWrapper 0.1.0


From: Richard Stonehouse
Subject: Re: ANN: GNUstepWrapper 0.1.0
Date: Wed, 1 Sep 2004 00:08:22 +0100

Raffi,

Apologies for the delay in following up - due to a system upgrade and a
week off. Some further info:

The message <address@hidden>
from "Raffael Herzog" <address@hidden> contains these words:

> On Sun, 15 Aug 2004 23:34:39 +0100, Richard Stonehouse  
> <address@hidden> wrote:

> > 1. Changes to the "Actions" sections do not always seem to "take". [...]

> Ooops, serious bug, IMHO. I'll look into this ASAP.

It now seems to do a bit better using gnustep-make/base 1.9.2,
gnustep-gui/back 0.9.3 and GWorkspace 0.6.5, than it did before using
gnustep-make/base 1.9.1, gnustep-gui/back 0.9.2 and GWorkspace 0.6.3.
(The underlying distro including kernel, X-windows, compiler and ffcall
versions have also changed, but I suppose any difference is most likely
to be due to the GNUstep components).

Under the old system, creating a new app wrapper, I found:

  - Changes to the "Start Application" script seemed to stick;

  - When I changed the "Start Application and Open Files" script, then
    went to the "Open Files in Running Application" script, then went
    back to the "Start Application and Open Files" script, I found it
    had reverted to its former contents;

  - Similarly with the "Open Files in Running Application" script, when
    I changed it, went to one of the other items then went back, it had
    gone back to the previous contents.

Under the new system, changes to the "Start Application" and "Start
Application and Open Files" scripts seemed to stick, but changes to the
"Open Files in Running Application" script sometimes didn't (I say
sometimes because I think on one occasion it did stick).

> > 2. Dragging and dropping icons to the Wrapper Factory window does not
> > seem to work for me, even if I turn on the GWorkspace desktop:
> >
> >   (a) Only TIFFs appear to work at all. But even for TIFFs,
> >       although drag and drop appears to have worked - the
> >       icon shows in the Wrapper Factory window - the icon
> >       file is not included in the App Wrapper that is saved.
> >       However, if I copy the TIFF to the App Wrapper by
> >       hand, and edit its name into the Info-gnustep.plist,
> >       GWorkspace doesn't display it.

The last line above contains a typo - for "doesn't" read "does". Apologies.

In a couple of tests on the new system, in one instance it did actually
copy the new icon and in the other it didn't. The difference may have
been that I was creating a new app wrapper in the case where it didn't
work, and editing the app wrapper in the case where it did work.

[...]

> Do XPMs and PNGs work with other GNUstep apps (e.g. Inspector.app)?

gif, png and tiff work in the Contents viewer, but xpm gives "Invalid
Contents"

-- 

    Richard Stonehouse




reply via email to

[Prev in Thread] Current Thread [Next in Thread]