discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libobjc2 build issue


From: Fred Kiefer
Subject: Re: libobjc2 build issue
Date: Wed, 27 Nov 2019 09:37:27 +0100

> Am 27.11.2019 um 06:55 schrieb Patryk Laurent <address@hidden>:
> 
> Hi Andreas,
> 
> I have just updated the script at 
> 
> https://github.com/plaurent/gnustep-build/blob/master/debian-10-clang-8.0/GNUstep-20-buildon-debian10.sh
> 
> and verified that it builds fully under Debian 10 (buster) by testing it 
> under a fresh Docker installation.  It also builds the apps (like Gorm).
> 
> That script was failing to apt-get some dependencies because libicu's version 
> (name) changed.  Also it was not doing the libobjc2 git submodule init.
> 
> That script now correctly does both of those.
> 
> Best,
> Patryk

Thank you for updating this instruction file. Is there a link to this in the 
GNUstep wiki? I understand that we should make it as easy as possible for new 
(and experienced) programmers to grab the correct instructions the first time.
For me this reoccurring build issues are one of the reasons why I do not use 
clang and the new runtime. They both develop too fast for me. It is quite 
normal that things change and from time to time they are even broken. If I 
remember correctly most of the questions on the development mailing list in 
recent years where caused by this. I prefer to spend my little time on GNUstep 
itself and not on fixing the build infrastructure. (Resulting in a less than 
optimal GNUstep environment for me.) What we need to do is minimise the pain 
for people who choose the other way. 

Fred


reply via email to

[Prev in Thread] Current Thread [Next in Thread]