[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Boostrap error

From: Jason Rumney
Subject: Re: Boostrap error
Date: Mon, 08 Nov 2004 10:30:32 +0000
User-agent: Mozilla Thunderbird 0.9 (Windows/20041103)

Jan D. wrote:

Guy Gascoigne-Piggford <address@hidden> writes:

Doing a make bootstrap I've started getting an error loading
encoded-kb.  This is in a completely fresh directory tree, so I don't
think that this is the same problem as the other boostrap error (where
certain .elc files remain and cause problems).

Does this look familiar to anyone?

make[1]: Entering directory `/cygdrive/c/dev/emacs-src/emacs/lisp'

This is the Cygwin make problem that is mentioned in nt/INSTALL, and
was discussed last week. Please try the patch Stefan posted in the
thread "autoload failure" (I don't seem to have the message anymore,
but you should be able to find it in the archive on lists.gnu.org). We
are still waiting for someone to report whether it works or not on

FWIW, setting buildlisppath to the real DOS path worked for me, i.e.

> make buildlisppath=c:/dev/emacs-src/emacs/lisp

for the case above. I don't know if there is a cygwin command to convert a cygwin path to a DOS path, but if there is, this could be done in the nt/makefile.

    Jan D.

We have tried that before, there are different versions of cygpath that are command-line compatible so it causes more problems than it solves. It would be far more useful to us if someone tried Stefan's patch instead of suggesting other workarounds.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]