[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Boostrap error

From: Jan D.
Subject: Re: Boostrap error
Date: Mon, 08 Nov 2004 18:40:53 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

Jason Rumney wrote:
Jan D. wrote:

FWIW, setting buildlisppath to the real DOS path worked for me, i.e.

> make buildlisppath=c:/dev/emacs-src/emacs/lisp

for the case above. I don't know if there is a cygwin command to convert a cygwin path to a DOS path, but if there is, this could be done in the nt/makefile.

    Jan D.

We have tried that before, there are different versions of cygpath that are command-line compatible so it causes more problems than it solves.

Too bad, it is the most general solution, but I guess it is too cygwin version specific.

Anyway, what I suggested is for a regular build only, for a bootstrap one has to add lisp=c:/dev/emacs-src/emacs/lisp to the make command.

I think it is something worth adding to nt/INSTALL, it is a better advice than "dont use cygwin make". After all, Stefans patch only handles the case where the cygwin prefix is just /cygdrive, which it isn't for me, but I've changed it to that for the test. I also have c: and d: mounted on /c and /d respectively (I don't know how common that is, but the cygwin documentation suggests it), so I don't use the cygwin prefix paths, but for this test I did.

> It would be far more useful to us if someone tried Stefan's patch
> instead of suggesting other workarounds.

Stefans patch has a syntax error (one parentesis too many in w32-cygdrive-run-real-handler), but apart from that, it fails with:

"./../bin/emacs.exe" -batch --no-init-file --no-site-file --multibyte -l autoload \
        --eval '(setq find-file-hook nil \
                find-file-suppress-same-file-warnings t \
                generated-autoload-file \
                  "/cygdrive/d/src/emacs-cygwin/lisp/loaddefs.el")' \
-f batch-update-autoloads /cygdrive/d/src/emacs-cygwin/lisp calc calendar emacs-lisp emulation eshell gnus international language mail mh-e net obsolete
 play progmodes term textmodes toolbar url
Wrong number of arguments: #<subr expand-file-name>, 3
Signal 127
make[1]: *** [autoloads] Error 255
make[1]: Leaving directory `/cygdrive/d/src/emacs-cygwin/lisp'
make: *** [bootstrap-gmake] Error 2

That lisp section is a bit over my head, so I did not find an apparent fix.

        Jan D.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]