[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Possible emacs bug when type password fields

From: Harald Hanche-Olsen
Subject: Re: Possible emacs bug when type password fields
Date: Fri, 01 May 2009 18:42:11 +0200 (CEST)

+ Borja Tarraso Hueso <address@hidden>:

> I was wondering if this is a known issue or not, but it seems some emacs
> bug, when I tried M-x gnus or M-x erc or any other feature in emacs (it
> means that is not emacs specific feature bug) I cannot use num keypad to
> type the password field. I tried in two different computers, with two
> different emacs versions, and different features, with same results.

It is more easily reproduced by typing

  M-: (read-passwd "Try it: ") RET

and typing some characters from the numeric keypad.

The problem seems to be that read-passwd does its own event processing,
and it doesn't recognize key translations such as kp-1 -> 1, etc.
(Type C-h k followed by 1 on the numeric keypad to see what I mean.)

(I see this with the x11 window system, not with nextstep, where that
translation happens at the OS level. Quite possibly, you don't see it
on windows either.)

More of a misfeature than a bug perhaps, but it would be worth fixing
if it's not too much trouble.

- Harald

reply via email to

[Prev in Thread] Current Thread [Next in Thread]