[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Readings for an emacs package maintainer ?

From: Xavier Maillard
Subject: Readings for an emacs package maintainer ?
Date: Mon, 01 Jun 2009 09:18:35 +0200
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.7 (Sanjō) APEL/10.7 Emacs/23.0.93 (i486-slackware-linux-gnu) MULE/6.0 (HANACHIRUSATO)
User-agent: Rmail GNU emacs 23.0 on Slackware 12.2.0


I am looking for a good documentation on best practices for an
emacs package maintainer.

I want packages I am maintaining to be still supported for old
emacsen from, say, 19.x to latest possible (including xemacs).

Currently, the big problems for me is to keep on using old
functions or have a common rule to define my macros.

What do you, emacs developers, do in order to have the larger
backward compatibility spectrum ?

I was thinking about a package-compat.el but I do not know how
well it will work with macros defined here at compile time.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]