[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Set the version number in the texinfo manuals using configure

From: Eli Zaretskii
Subject: Re: Set the version number in the texinfo manuals using configure
Date: Sat, 30 Oct 2010 23:10:42 +0200

> Date: Sat, 30 Oct 2010 22:50:23 +0200
> From: martin rudalics <address@hidden>
> CC: address@hidden
>  > So it's not like it succeeds the second time, it always fails for
>  > you.  It's just that the --force switch forces it to build the Info
>  > manual regardless of the error.
> But it somehow stops after the error the first time and builds the
> remaining files only the second time (at least I think so).

Because makeinfo exits with an error status, and Make stops.  IOW,
using the --force switch to makeinfo prevents it from deleting the
produced Info file, but does not prevent it from returning an exit
status that indicates an error.

> make   -C ../doc/misc info
> make[1]: Entering directory `C:/emacs/trunk/doc/misc'
> makeinfo --force -I./../emacs faq.texi
> makeinfo --force calc.texi
> calc.texi:10: @include `emacsver.texi': No such file or directory.
> make[1]: *** [../../info/calc] Error 1

That's definitely an old makefile, from before the latest changes to
makefile.w32-in: the command for faq.texi includes the -I switch,
while the command for calc.texi does not.  Please show the full
doc/misc/makefile you have.  Also, please look into the doc/misc
directory and tell which files you have there that match the wildcard
"*make*" (e.g. "dir *make*" should show that).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]