[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Still unable to build trunk

From: Jim Meyering
Subject: Re: Still unable to build trunk
Date: Sun, 23 Jan 2011 16:33:00 +0100

Eli Zaretskii wrote:
>> Date: Fri, 21 Jan 2011 23:25:26 -0800
>> From: Paul Eggert <address@hidden>
>> Cc: Jan Djärv <address@hidden>, address@hidden
>> One way to address this issue is to say that maintainers should
>> have automake installed.  That's normal for other packages, but
>> I'd rather minimize changes to the assumptions for Emacs.
> What is the meaning of "maintainers" in this context?  Does that mean
> anyone who builds the development trunk?  If so, that's a very large
> population, most of them not really "maintain" Emacs, and I'm not sure
> we want to request that all of them have automake installed.
> In any case, if we do, there should be clear information about the
> version(s) of all the auto-tools that are required to build Emacs
> correctly and seamlessly.  The file INSTALL.BZR in the top-level
> directory sounds like the right place.  It currently says nothing
> about these requirements, AFICS.

Hi Eli,

By "maintainers", he meant "anyone who builds from VC-cloned sources."

In many gnulib-using projects, we address two types of
users who build from source:
  - those who build from a distribution tarball
  - those who build from upstream clone/checkout

Obviously, when building from a tarball, there are only the usual, minimal
requirements specified in the GCS.  E.g., use of autoconf, automake, makeinfo,
etc. are not required.

However, those who build from the latest sources, as checked out
from version control must have tools that meet certain standards.
In coreutils, for example, we address that with the combination
of documentation via two README files:


  # We also have HACKING, but it targets those contributing patches:

and an automated check for the presence and minimal-acceptable versions
of build-related tools (this is from bootstrap.conf):

  # Build prerequisites
  autoconf   2.62
  automake   1.11.1
  autopoint  -
  bison      -
  gettext    0.17
  git        1.4.4
  gperf      -
  gzip       -
  makeinfo   -
  patch      -
  perl       5.5
  rsync      -
  tar        -
  xz         -

Since anyone building coreutils from VC'd sources must run our
./bootstrap script, they will learn very quickly if they lack one
of the required build tools.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]