[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/4] Refactor window-system configuration

From: Stefan Monnier
Subject: Re: [PATCH 2/4] Refactor window-system configuration
Date: Thu, 29 Dec 2011 19:53:52 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.92 (gnu/linux)

>> We don't use something like "#include TERM_HEADER" in any other place,
>> it you really want to consolidate this stuff, creating a new header
>> file to include seems better.
> There's a first time for everything, and besides: other projects have
> successfully used this approach. My initial revisions actually did
> exactly what you suggest, but I realized that the solution was more
> complex and didn't actually have any benefit.
> Besides, we have src/s/*.h and src/m/*.h. At least this approach is
> explicit.

I guess "#include TERM_HEADER" is OK for "now" (i.e. for when the trunk
gets unfrozen).

>> Also "TERM" does not look like a good prefix
>> in this case, it's meaning might be confused with the TERM environment
>> variable (nsterm/w32term/xterm are not that great either, but better not
>> propagate the confusion).
> "Term", I think, it pretty clear in the context of Emacs. Using a
> different name for the header constant wouldn't change the names of all
> the datatypes in that header. It's better to at least be consistently
> confusing.
> There's XTERM_HEADER, but this name has other issues.

We need to create a new file where we can put the common code shared
between the various *term.c files.  Not sure how we could/should call
this file, but it could be "guiterm.c", in which case GUITERM_HEADER
might make sense as well.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]