[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/4] Refactor window-system configuration

From: Eli Zaretskii
Subject: Re: [PATCH 2/4] Refactor window-system configuration
Date: Fri, 30 Dec 2011 10:21:34 +0200

> Date: Thu, 29 Dec 2011 14:29:24 -0800
> From: Daniel Colascione <address@hidden>
> Cc: address@hidden
> My initial revisions actually did exactly what you suggest, but I
> realized that the solution was more complex and didn't actually have
> any benefit.

Can you describe the complexity in this solution?

> > Also "TERM" does not look like a good prefix
> > in this case, it's meaning might be confused with the TERM environment
> > variable (nsterm/w32term/xterm are not that great either, but better not
> > propagate the confusion).
> "Term", I think, it pretty clear in the context of Emacs. Using a
> different name for the header constant wouldn't change the names of all
> the datatypes in that header. It's better to at least be consistently
> confusing.
> There's XTERM_HEADER, but this name has other issues.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]