[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/4] Refactor window-system configuration

From: Daniel Colascione
Subject: Re: [PATCH 2/4] Refactor window-system configuration
Date: Fri, 30 Dec 2011 00:26:45 -0800
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20111105 Thunderbird/8.0

On 12/30/11 12:21 AM, Eli Zaretskii wrote:
>> Date: Thu, 29 Dec 2011 14:29:24 -0800
>> From: Daniel Colascione <address@hidden>
>> Cc: address@hidden
>> My initial revisions actually did exactly what you suggest, but I
>> realized that the solution was more complex and didn't actually have
>> any benefit.
> Can you describe the complexity in this solution?

configure already knows what window system we're using, so it can set a
macro to the name of the correct header without further logic.  Nobody
else has to be aware of the set of possible window systems.

On the other hand, using a fixed "dispatch header" --- i.e., one that
contains a bunch of preprocessor branches and include directives ---
forces us to create yet another place that has to know about all
possible window systems.

>>> Also "TERM" does not look like a good prefix
>>> in this case, it's meaning might be confused with the TERM environment
>>> variable (nsterm/w32term/xterm are not that great either, but better not
>>> propagate the confusion).
>> "Term", I think, it pretty clear in the context of Emacs. Using a
>> different name for the header constant wouldn't change the names of all
>> the datatypes in that header. It's better to at least be consistently
>> confusing.
>> There's XTERM_HEADER, but this name has other issues.
> How about WINSYS_HEADER?

That's fine.

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]