[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Rename `eww' to `web'

From: Juri Linkov
Subject: Re: Rename `eww' to `web'
Date: Sat, 06 Jul 2013 02:29:43 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (x86_64-pc-linux-gnu)

> Defining entry points is as easy as
> ;;;###autoload
> (define-dispatcher browse)
> etc. Where would they go? In dispatcher.el?

`dispatcher' is a too technical term.  A more user-friendly term would be
`alternatives' like you can see on GNU/Linux in /etc/alternatives/ that
can be customized with such commands:

  update-alternatives --config x-www-browser
  update-alternatives --config gnome-www-browser

Using similar names like `alternatives-define' and more specific
`www-browser-alternatives' or `browse-web-alternatives'
would be more familiar to the users of GNU/Linux.

IOW, you took the subject of 
too literally.  There is no word "dispatcher" anywhere in command and variables
proposed by Stefan in this message.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]