[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Latest git sources fail to compile w/gnutls on debian stable

From: Harry Putnam
Subject: Latest git sources fail to compile w/gnutls on debian stable
Date: Sun, 30 Apr 2017 10:28:12 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

My setup:
  Debian stable (jessie) running in vbox vm on windows 10 64bit

As a longtime user of gnus and emacs I compile from source

Attempting to build latest emacs I run into a problem gnutls not being
available.  This is not a new problem for me.

I've had this failure for good few months but was able to compile
--with-gnutls=no and still have gnus work on nntp (mostly gmane)
imap (some on google some on fastmail.fm).  Seems to find a way to negotiate 
with imap servers
using gnutls-cli.... that is without any thing special done. 

However doing that (compiling --with-gnutls=no) this time and I find I
cannot access the imap groups .. some on google and some on fastmail.fm

So, on latest sources:

  ./configure --prefix=/usr/local/src/vcs/git/test --with-x=yes
       --with-x-toolkit=athena  --with-imagemagick
           --with-gpm --with-sound=no
  configure: error: The following required libraries were not found:
  Maybe some development libraries/packages are missing?
  If you don't want to link with them give
  as options to configure

I have these gnutls related pkgs installed:

  i A libcurl3-gnutls       - easy-to-use client-side URL transfer libra
  i   libgnutls-deb0-28     - GNU TLS library - main runtime library    
  i   libgnutls-openssl27   - GNU TLS library - OpenSSL wrapper         
  i A libneon27-gnutls      - HTTP and WebDAV client library (GnuTLS ena

I suspect it might be the dev pkgs that is needed:


But when I try to install it, I run into a complicated dependency
problem I don't know how to solve:

  aptitude install libgnutls-dev

  The following NEW packages will be installed:
    libgcrypt11{a} libgcrypt11-dev{ab} libgcrypt20-dev{a} libgnutls-dev{b} 
    libgnutls26{a} libgnutlsxx27{a} libgpg-error-dev{a} libp11-kit-dev{a} 
    libtasn1-3{a} libtasn1-3-dev{a} 
  0 packages upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
  Need to get 2,990 kB of archives. After unpacking 7,831 kB will be used.
  The following packages have unmet dependencies:
   libgnutls-dev : Depends: libgnutls-openssl27 (= 2.12.20-8+deb7u5) but 
3.3.8-6+deb8u4 is installed.
   libgcrypt11-dev : Breaks: libgnutls-dev (< 2.12.23-18) but 2.12.20-8+deb7u5 
is to be installed.
  The following actions will resolve these dependencies:

       Keep the following packages at their current version:
  1)     libgnutls-dev [Not Installed]                      

  Accept this solution? [Y/n/q/?]

The offered solution ends with libngutls-dev NOT installed.

I walked thru several other solutions by pressing `. <ENTER>'

But none of the first 6 offer a way to end up with libgnutls-dev
installed.  I quite after 6 offerings.

I'm not even sure that is the missing pkg to allow emacs to compile
with gnutls...

I'm not really eager to meddle with my OS... I'm running stable for a

I considered compiling gnutls from source and started into doing that,
but decided that was a good bit more complicated and  out of my skill range.

Hopefully someone here will have experience compiling emacs with gnutls
and will know or have a good idea what needs to be done here.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]