[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest git sources fail to compile w/gnutls on debian stable

From: Paul Eggert
Subject: Re: Latest git sources fail to compile w/gnutls on debian stable
Date: Sun, 30 Apr 2017 14:35:40 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.8.0

To be honest I'm not sure I would mess with this stuff if you're not an expert. I.e., if you want to run more-bleeding-edge software, by far the easiest way to do that is to upgrade to a more-bleeding-edge version of Debian.

That being said, the Debian package list doesn't list any "libgnutls-dev" package for jessie, which is the current Debian stable. That is, https://packages.debian.org/jessie/libgnutls-dev reports an error. If you are getting libgnutls-dev from some source other than Debian, that might explain the problem - but then, this would not match your desire to run a stable version, so I am puzzled as to what your system's state is. You might want to audit /etc/apt/sources.list before proceeding.

   libgnutls-dev : Depends: libgnutls-openssl27 (= 2.12.20-8+deb7u5) but 
3.3.8-6+deb8u4 is installed.

jessie's libgnutls-openssl27 is indeed 3.3.8-6+deb8u4 currently; at least, that's what https://packages.debian.org/jessie/libgnutls-openssl27 says. 2.12.20-8+deb7u5 is for wheezy, which is the obsolete stable release. Perhaps you installed some wheezy packages atop a jessie system a while ago? or are trying to do the reverse? I'm not sure I'd recommend that....

reply via email to

[Prev in Thread] Current Thread [Next in Thread]