[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs's set-frame-size can not work well with gnome-shell?

From: Dmitry Gutov
Subject: Re: Emacs's set-frame-size can not work well with gnome-shell?
Date: Tue, 28 Jan 2020 02:20:31 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

On 26.01.2020 20:38, martin rudalics wrote:
Don't you have some old laptop somwehere where you could try the
experiments without scaling (I'd never believe that changing scaling
on-the-fly works always in a reproducible fashion).

So, I tried this stuff on an old laptop. Ubuntu 16.04, with whatever version of Unity was there, as well as with GNOME Shell 3.18 (and the same version of GTK3 in both cases). No scaling.


Child frame resizes fine, just like in all other DEs aside from Mutter, apparently.


Child frame does not resize, even using these rather old GNOME Mutter and GTK.

Dragging a normal un-decorated Lucid frame is smooth-ish (with pauses). Although I hadn't tried the more involved experiment involving a child frame.

In both:

Normal un-decorated frames have exactly the same drag-resizing behavior problem that I described before, so it's definitely not HiDPI-related.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]