[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug#54458: 27.2; erc-dcc-get: Re-entering top level after C stack ov

From: Fernando de Morais
Subject: Re: bug#54458: 27.2; erc-dcc-get: Re-entering top level after C stack overflow
Date: Sun, 24 Apr 2022 21:59:27 -0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.1 (gnu/linux)

Hello J.P.,

Once more, sorry for the late response.

"J.P." <jp@neverwas.me> writes:

>> Did you mean successively or simultaneously? Because when attempting
>> the latter, I can't even get off the ground.

Precisely! My problem was in the simultaneous transfers.

>> When you get a chance, please try the proposed multi-file fix, even
>> though it does nothing for the unresponsiveness problem.

I tested your patch (0003) and it worked the way you detailed: now I can
do more than one transfer simultaneously, however, at some point I lose
control of Emacs and regain it, completely, only when the transfers are

>> Also, if it's not too much trouble, would you mind doing something
>> like

Not trouble at all! But, unfortunately, I believe I did something wrong
when running `tcpdump' command, as it did not detect any files
transferred through DCC GET in my tests and the dump file generated was
always the same, 24 bytes, containing only one line.

My command was the same as yours (as root):

   # tcpdump -i <my-interface> -Uw ./dump 'host <my-host-ip> and tcp port 

Is there anything else that I need to do/know about this command to
generate the desired dump for you?

> Another possibility I've been kicking around is (optionally) running
> DCC GET operations in a subprocess. Attached is a POC (patch #4),
> which I'm hoping you'll try. Unfortunately, like patch #2, I believe
> it'll only apply cleanly on newer Emacs versions. (You'll also be
> needing to set the option `erc-dcc-get-use-subprocess' to t.)

I found this approach very interesting and as soon as I could I tried to
test it, but even in Emacs 28.1 I get the following error messages:

   error in process sentinel: erc-format-message: No format spec for message 
   error in process sentinel: No format spec for message dcc-get-failed

Is this an issue specific to the versions of Emacs (27.2 and 28.1) I
tested it on?

Thank you so much for keeping investigating possible solutions. I'll be
using your patches #2 and #3.

Fernando de Morais.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]