[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug#54458: 27.2; erc-dcc-get: Re-entering top level after C stack ov

From: J.P.
Subject: Re: bug#54458: 27.2; erc-dcc-get: Re-entering top level after C stack overflow
Date: Mon, 25 Apr 2022 05:08:52 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50 (gnu/linux)

Fernando de Morais <fernandodemorais.jf@gmail.com> writes:

> Once more, sorry for the late response.

Not a problem! Plenty to do around here.

> I tested your patch (0003) and it worked the way you detailed: now I can
> do more than one transfer simultaneously, however, at some point I lose
> control of Emacs and regain it, completely, only when the transfers are
> finished.

I "believe" the simultaneous-receive problem and the loss-of-control
issue are unrelated (despite the second being exacerbated by the first).

> I believe I did something wrong when running `tcpdump' command, as it
> did not detect any files transferred through DCC GET in my tests and
> the dump file generated was always the same, 24 bytes, containing only
> one line.

No worries. I'll just assume the sender is behaving aberrantly. The
thing is, I still haven't been able to repro this with a real client as
sender. And when I asked around to see if anyone else has encountered
anything related, e.g.,

1. senders that never read
2. clients that always act defensively

I only got crickets for the second and for the first was told there's a
variant of the protocol (or some extension) called TSEND, which might be
to blame if enabled by a sender.

That said, I don't see an obvious problem with applying some version of
the proposed patches because we wouldn't be impacting routine behavior,
AFAICT. And since DCC has basically been deprecated for years, the risk
of incurring related hate mail is low should this observation prove

> I found this approach very interesting and as soon as I could I tried to
> test it, but even in Emacs 28.1 I get the following error messages:
>    error in process sentinel: erc-format-message: No format spec for message 
> dcc-get-failed
>    error in process sentinel: No format spec for message dcc-get-failed
> Is this an issue specific to the versions of Emacs (27.2 and 28.1) I
> tested it on?

Hm. And you applied *all* the patches as a sequence? I.e.,

  git am ~/somedir/000{1..4}-*.patch

Because the format spec lives in the first one:


So that needs to be present (as do the rest). IOW, in this capacity,
they're acting as a set (not v1..vN iterations). Can you compare your
version of erc-dcc.el to the one on HEAD? BTW, I know for sure that they
won't apply cleanly on 27 (but they "should" on 28).

> Thank you so much for keeping investigating possible solutions. I'll be
> using your patches #2 and #3.

My pleasure! Thanks for reporting this. (FWIW, the subprocess thing
worked for me, but YMMV.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]