[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] org-file using tramp + babel?

From: Martin Yrjölä
Subject: Re: [O] org-file using tramp + babel?
Date: Fri, 15 Jan 2016 08:41:58 +0200
User-agent: mu4e 0.9.15; emacs

Hi John,

John Kitchin <address@hidden> writes:

> Hi, I opened an org file using tramp on a remote server. It opened fine,
> and I had no trouble writing text and saving it. For fun I tried running
> a src block (a shell block that just returned the hostname), and got
> this error:
> tramp-file-name-handler: Couldn't write region to
> `/scp:address@hidden:/var/folders/5q/lllv2yf95hg_n6h6kjttbmdw0000gn/T/ob-input-30024dza',
> decode using `base64 -d -i >%s' failed
> Should this have worked? It looks like it tried to write a local path
> from my Mac to the server, and that path doesn't exist there.
> Some details (not sure they are relevant):
> I am running Emacs on a Mac, and opened a file on a remote Centos5
> server.

Howard Abrams has written an extensive answer to this problem in his
blog [1]. The problem is that the Mac uses a different folder for
temporary files. Howard also proposes a fix and refers to a mailing list
message regarding the bug [2].

Hope this helps,

[1] http://www.howardism.org/Technical/Emacs/literate-devops.html#fn.2
[2] http://lists.gnu.org/archive/html/emacs-orgmode/2013-09/msg00992.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]