[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Search for an entry expands parent

From: Kyle Meyer
Subject: Re: Search for an entry expands parent
Date: Sat, 18 Jul 2020 11:48:29 -0400

Gt Uit writes:

> Updates since my last email:
> - Sometimes the first C-s yields intended result (minimal), with
> subsequent C-s searches expanding all entries.
> - I tried on Emacs 28.0.50 and am getting the same results.
> - I tried with emacs -Q and isearch minimal behaves properly!
> - I tried a live distribution (Linux Mint 20 Ulyana, same
> distribution I am currently using) and isearch minimal behaves
> properly.
> - I tried the following without any success:
> + Remove all emacs related packages and reinstall emacs (via apt)
> + Install emacs from snap.
> Now that I have narrowed down the bug to be something local to my
> current installation please advise on how to debug/resolve.

Something that might give you a clue about what's going on is stepping
through org-show-set-visibility, comparing what happens when it works as
expected and what happens when it doesn't.  If you haven't used Edebug
before, take a look at its node in the Elisp manual:
(info "(elisp)Edebug")

reply via email to

[Prev in Thread] Current Thread [Next in Thread]