[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Search for an entry expands parent

From: Gt Uit
Subject: Re: Search for an entry expands parent
Date: Mon, 20 Jul 2020 10:18:18 +0300

18.07.2020, 18:48, "Kyle Meyer" <kyle@kyleam.com>:

Gt Uit writes:

 Updates since my last email:
 - Sometimes the first C-s yields intended result (minimal), with
 subsequent C-s searches expanding all entries.
 - I tried on Emacs 28.0.50 and am getting the same results.
 - I tried with emacs -Q and isearch minimal behaves properly!
 - I tried a live distribution (Linux Mint 20 Ulyana, same
 distribution I am currently using) and isearch minimal behaves
 - I tried the following without any success:
 + Remove all emacs related packages and reinstall emacs (via apt)
 + Install emacs from snap.
 Now that I have narrowed down the bug to be something local to my
 current installation please advise on how to debug/resolve.

Something that might give you a clue about what's going on is stepping
through org-show-set-visibility, comparing what happens when it works as
expected and what happens when it doesn't. If you haven't used Edebug
before, take a look at its node in the Elisp manual:
(info "(elisp)Edebug")

Thanks for pointing me to Edebug, a tremendously useful tool.
I got the following:
 - Executed:
   + M-x find-function org-show-set-visibility
   + C-u C-M-x (edebug-defun)
 - The first time I launch emacs, the function org-show-set-visibility is
   called and I can step through the code via Edebug
- Subsequent calls do not invoke org-show-set-visibility
I didn't mention earlier that I got this bug after upgrading from Linux
Mint 19.3 to Linux Mint 20.
Can you please point me to what to further debug, in particular function
that is called before org-show-set-visibility.
Gt Uit

reply via email to

[Prev in Thread] Current Thread [Next in Thread]