[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: org-meta-return / org-insert-heading does not insert new heading in

From: Ihor Radchenko
Subject: Re: org-meta-return / org-insert-heading does not insert new heading in middle of heading even id org-M-RET-may-split-line is set
Date: Fri, 08 Jul 2022 12:49:16 +0800

Guillaume MULLER <guillaume.muller@univ-st-etienne.fr> writes:

>> I tried to set org-M-RET-may-split-line to nil first followed by setting
>> it to either t or '((default . t)). For both values, I am seeing
>> * heading number
>> * <>one
>> which is expected behavior.
> Are you using DoomEmacs or Vanilla Emacs?

I am using Vanilla Emacs.
Note that Doom is known for carelessly advising some Org functions and
can sometimes break things. Such issues should be reported to Doom

> More precisely, are you using org-mode "9.6-??-e9da29b6f" as I do? (This is 
> the only version that gives me the strange behavior)

There is no such Org version. Our latest version tag is 9.5.4.
If you are seeing 9.6-..., it indicates some problem with your package
manager. I suggest to purge your local downloaded Org copy and
re-install Org.

>> Please, try to reproduce starting from emacs -Q (without Doom).
>> See https://orgmode.org/manual/Feedback.html

> What I tried:
> - Getting an as-vanilla-as-possible DoomInstall, by removing my config.org 
> and sync'ing Doom. I get the same "9.6-??-e9da29b6f" org version and 
> erroneous behavior.

9.6 means that your Doom is not clean enough. There is some problem with
your Org source code used by Doom.

> - Changing the version of org-mode used in Doom, by removing the directory 
> and installing the one from MELPA (9.5.4). This gives me the correct behavior 
> for org-meta-return, but it breaks too many other things in org to be usable.

What do you mean by "breaks too many other things in org"?

> - Using "vanilla" "emacs -Q" and running only org "9.6".
>   1. I've tried to manually load the org-version that comes with Doom, by 
> writing & executing "(add-to-list 'load-path 
> "/home/user/.emacs.d/modules/lang/org/lisp/autoload") (load "org")" from 
> scratch buffer, then running org-reload
>    + but I get org-version 9.3
>    + and I can't find a way to edit the "load-path" "variable" to remove the 
> native path ("/usr/share/emacs/27.1/lisp/org") from the list (sorry newbie 
> here...)

I do not think that "/home/user/.emacs.d/modules/lang/org/lisp/autoload"
contains Org source. AFAIK, Doom using using straight.el, which puts the
packages sources into .emacs.d/straight/repos/ and
.emacs/straight/build/. Though Doom might use different paths.

You can try to watch the video I recorded on testing Org issues:
There, I showcased how to get a clean Org setup + vanilla Emacs.

>   2. I've tried to git clone the org-mode repo in /tmp, but don't see any 
> tag/branch that would correspond to a "9.6" version of org.
>   + I do see a commit matching e9da29b6f 
> (e9da29b6fafe63abbc2774e9d485ac13d2811b65)
>     * I've tried to recover the code from this version "git checkout 
> e9da29b6f ."
>     * Compiled it (make)
>     * Opened emacs -Q
>     * Wrote and executed "(add-to-list 'load-path "/tmp/org-mode/lisp/") 
> (load "org")" in the scratch buffer
>     * Ran M-x org-reload
>     + But "M-x org-version" still returns "Org mode version 9.5.4", and it 
> works as expected
> If you have any more hints on how I could setup an environment where I could 
> test just org-mode "9.6-??-e9da29b6f" on a raw/vanilla emacs, I vwould be 
> glad to test that.

Again, there is no such tag. There is official release version, which is
9.5.4; and there are two development branches: bugfix and main. The
bugfix is WIP minor release branch for 9.5.5 and main is the development
branch for next major release. Note that Doom is using the development
(main) branch, AFAIK.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]