[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [emms-help] emms-player-mpv ipc-error: connection-error

From: Mike Kazantsev
Subject: Re: [emms-help] emms-player-mpv ipc-error: connection-error
Date: Thu, 7 Jun 2018 01:28:47 +0500

On Mon, 4 Jun 2018 17:37:52 +0500
Mike Kazantsev <address@hidden> wrote:

> On Mon, 04 Jun 2018 13:59:15 +0300
> Konstantin Reich <address@hidden> wrote:
> > I have the same problem on my work and home computer, both have Ubuntu 
> > 18.10.  
> Given such signal exit, suspect that it might be some kind of bug in
> that specific mpv build.
> Will add more logging first though and report back.
> Might be able to reproduce it here in a VM as well, given that it's a
> stock distro, which should be easy to spin up.

Have tried to get same error in qemu/kvm on latest Ubuntu 18.10 iso from 
http://cdimage.ubuntu.com/daily-live/pending/ (latest is 2018-06-06 07:51 atm).
Pre-release version, since I think release for 18.10 should only be in october.

Did "apt install emacs emms mpv", copying over emms-player-mpv.el from
current git to ~/.emacs.d/lisp/, and using following emacs config:

  (require 'emms)
  (add-to-list 'load-path "/home/mk-fg/.emacs.d/lisp")
  (require 'emms-player-mpv)
    emms-player-list '(emms-player-mpv)
    emms-player-mpv-debug t)

  (defmacro iwrapm (func &rest args)
    `(lambda () (interactive) (,func ,@args)))

  (global-set-key (read-kbd-macro "<f5>")
    (iwrapm switch-to-buffer "*Messages*"))
  (global-set-key (read-kbd-macro "<f6>")
    (iwrapm emms-play-url "http://www.ibiblio.org/wcpe/wcpe.pls";))
  (global-set-key (read-kbd-macro "<f7>") 'emms)
  (global-set-key (read-kbd-macro "<f8>") 'emms-add-directory)

Pressing F5 and F6 in sequence opened Message buffer there and started
playing specified playlist without any issues.

mpv there seem to be same version as you use - 0.27.2, though it reports 
"ffmpeg version: 3.4.2-2build1" instead of simply "3.4.2-2" in your
--version output.
Package versions: mpv 0.27.2-1ubuntu1, libav* 3.4.2-2build1.

So doesn't look like it's due to distro-specific mpv build, at least at
this point.

I'd suggest to:

 - Run "apt upgrade" - see if maybe some libs on your machines were
   updated roughly at the same time and had some issue that's resolved
   in the repos by now.

 - Run mpv with socket option without emacs:

     mpv --quiet --really-quiet --no-audio-display --idle \

   See if it crashes - probably should, as emacs does same thing.

 - If it does crash, re-run it as "strace -f -s16384 ... 2>mpv-strace.log",
   where ... is the same command, check or attach mpv-strace.log to an
   email here, which might help to see what mpv does last before the
   crash in rough syscall outlines.

 - If that doesn't help, or you have a bit more time on your hands,
   install gdb (GNU debugger) package, and run same command as "gdb
   -args ...", use "r" command in prompt there to start mpv, then
   "bt full" to see the backtrace once it crashes.

   Which might show which libs you need to install *-dbg packages for
   to see more useful info (with function names and arguments in
   there), then repeat the process.

Looks like either some issue specific to your setup (but shared on two
machines somehow), or maybe some faulty lib dependency in pre-release
18.10, either of which seem unlikely to be common.

So other than that workaround with 'file and looking more into the cause
on these systems as described above, can't think of anything else to suggest.

Mike Kazantsev // fraggod.net

reply via email to

[Prev in Thread] Current Thread [Next in Thread]