[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ESPResSo] Using VMD with Espresso

From: Lorenzo Isella
Subject: [ESPResSo] Using VMD with Espresso
Date: Tue, 2 Oct 2007 18:59:56 +0200

Dear All,
Perhaps I should be posting this in the VMD list, but I think it
should be trivial to have my little problem solved.
I am using Debian testing, there is no deb binary to download from the
vmd website, so I went for the source code.
Basically, I am rather incompetent when I have to build from source,
set the path and so on.
The espresso installation (the sequence configure-make-checkinstall
from the untarred directory) went fine on my system and also created a
new Espresso directory in my home with the espresso executable and
library files.
I can now run the tutorial after setting VMD offline and giving up
Now, I downloaded and untarred VMD, moving the plugin directory into
the newly created vmd directory.
Then here is what I did:

address@hidden:~/internet-download/vmd-1.8.6$ ./configure
using configure.options: WIN32 TCL
address@hidden:~/internet-download/vmd-1.8.6$ make
VMD Build Options
  Hardware accelerated versions:
      aix4.opengl       - AIX 4.3
      aix5.opengl       - AIX 5
   aix5.64.opengl       - AIX 5, 64-bit
    hpux11.opengl       - HP-UX 11.0
     irix6.opengl       - IRIX 6.5.x
  irix6.64.opengl       - IRIX 6.5.x, 64-bit
     linux.opengl       - Redhat Linux (32-bit)
     linux.cuda.opengl  - Redhat Linux (32-bit), NVIDIA CUDA
     linux.amd64.opengl - Redhat Linux (64-bit)
     linux.ia64.opengl  - Redhat Linux Itanium EL3 (64-bit)
    macosx.opengl       - MacOS X 10.2
    macosx.opengl.x11   - MacOS X 10.3
   solaris.opengl       - Solaris 9
solaris.64.opengl       - Solaris 9, 64-bit
     tru64.opengl       - Tru64 Unix 4.0F

  Non-accelerated versions:
        aix4.mesa - AIX 4.3
     freebsd.mesa - FreeBSD 5.x
      hpux11.mesa - HP-UX 11.0
       linux.mesa - Redhat Linux 7.x
  linuxalpha.mesa - Linux/Alpha
    linuxppc.mesa - Linux/PowerPC
      macosx.mesa - MacOS X 10.1
     solaris.mesa - Solaris 8
       tru64.mesa - Tru64 Unix 4.0F
Type 'make platform' to configure VMD for any of
the target platforms listed above.

Once VMD is configured for compilation, do this:
  cd src; make veryclean; make

address@hidden:~/internet-download/vmd-1.8.6$ make platform
make: *** No rule to make target `platform'.  Stop.
address@hidden:~/internet-download/vmd-1.8.6$ cd s
scripts/ shaders/ src/
address@hidden:~/internet-download/vmd-1.8.6$ cd s
scripts/ shaders/ src/
address@hidden:~/internet-download/vmd-1.8.6$ cd src/
address@hidden:~/internet-download/vmd-1.8.6/src$ make veryclean
cd ../WIN32 ; \
                rm -f *.o *.warnings *.depend.old core
rm -f vmd_python.C
cd ../WIN32 ; \
          rm -rf ; \
          rm -f vmd_WIN32
cd ../src ; \
          rm -f *.o *.a *~ core; \
          rm -rf ; \
          rm -f vmd_WIN32
cd ../doc ; \
          rm -f *~ core
address@hidden:~/internet-download/vmd-1.8.6/src$ sudo checkinstall

checkinstall 1.6.1, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
           This software is released under the GNU GPL.

The package documentation directory ./doc-pak does not exist.
Should I create a default set of package docs?  [y]:

Preparing package documentation...OK

*** No known documentation files were found. The new package
*** won't include a documentation directory.

Please write a description for the package.
End your description with an empty line or EOF.
>> new attempt to build vmd

**** Debian package creation selected ***

This package will be built according to these values:

0 -  Maintainer: [ address@hidden ]
1 -  Summary: [ new attempt to build vmd ]
2 -  Name:    [ src ]
3 -  Version: [ 20071002 ]
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ checkinstall ]
7 -  Architecture: [ i386 ]
8 -  Source location: [ src ]
9 -  Alternate source location: [  ]
10 - Requires: [  ]

Enter a number to change any of them or press ENTER to continue:

Installing with make install...

========================= Installation results ===========================
if [ ! -d "/usr/local/lib/vmd" ]; then \
                mkdir -p "/usr/local/lib/vmd" ; \
        fi ; \
        if [ ! -d "/usr/local/bin" ]; then \
                mkdir -p "/usr/local/bin" ; \
        fi ; \
        if [ ! -d "/usr/local/lib/vmd"/doc ]; then \
                mkdir -p "/usr/local/lib/vmd"/doc; \
cp ../Announcement  "/usr/local/lib/vmd"
cp ../README        "/usr/local/lib/vmd"
cp ../LICENSE       "/usr/local/lib/vmd"
cp ../doc/ug.pdf        "/usr/local/lib/vmd"/doc
if [ -f /usr/local/lib/vmd/vmd_WIN32 ]; then \
           mv -f "/usr/local/lib/vmd/vmd_WIN32"
"/usr/local/lib/vmd/OLD_vmd_WIN32" ; rm -f
"/usr/local/lib/vmd/OLD_vmd_WIN32" ; fi
cp ../WIN32/vmd_WIN32 "/usr/local/lib/vmd"
cp: cannot stat `../WIN32/vmd_WIN32': No such file or directory
make: [install] Error 1 (ignored)
cp ../lib/stride/stride_WIN32 ../lib/surf/surf_WIN32
../lib/tachyon/tachyon_WIN32 "/usr/local/lib/vmd"
cp: cannot stat `../lib/stride/stride_WIN32': No such file or directory
cp: cannot stat `../lib/surf/surf_WIN32': No such file or directory
cp: cannot stat `../lib/tachyon/tachyon_WIN32': No such file or directory
make: [install] Error 1 (ignored)
cd ..; tar -cf - scripts | \
        (cd "/usr/local/lib/vmd" ; tar -xf -)
cd ../lib; tar -cf - scripts | \
        (cd "/usr/local/lib/vmd" ; tar -xf -)
cd ..; tar -cf - python | \
        (cd "/usr/local/lib/vmd"/scripts ; tar -xf -)
cd ..; tar -cf - plugins | \
        (cd "/usr/local/lib/vmd" ; tar -xf -)
cd ..; tar -cf - shaders | \
        (cd "/usr/local/lib/vmd" ; tar -xf -)
cp ../data/.vmdrc ../data/.vmdsensors "/usr/local/lib/vmd"
cd ../bin ; \
        if [ -f run_vmd_tmp ]; then rm -f run_vmd_tmp; fi ; \
        echo '#!/bin/csh' >> run_vmd_tmp ; \
        echo 'set defaultvmddir="/usr/local/lib/vmd"' >> run_vmd_tmp ; \
        echo 'set vmdbasename=vmd' >> run_vmd_tmp ; \
        cat vmd >> run_vmd_tmp ; \
        chmod +x run_vmd_tmp ; \
        cp run_vmd_tmp "/usr/local/bin"/vmd ; \
        rm -f run_vmd_tmp
echo Make sure "/usr/local/bin"/vmd is in your path.
Make sure /usr/local/bin/vmd is in your path.
echo "VMD installation complete.  Enjoy!"
VMD installation complete.  Enjoy!

======================== Installation successful ==========================
grep: /var/tmp/DgbJQLofilokkYaqGZZZP/newfile: No such file or directory

Copying files to the temporary directory...OK

Striping ELF binaries and libraries...OK

Compressing man pages...OK

Building file list...OK

Building Debian package...OK

Installing Debian package...OK

Erasing temporary files...OK

Writing backup package...OK

Deleting temp dir...OK


 Done. The new package has been installed and saved to


 You can remove it from your system anytime using:

      dpkg -r src


Again sorry for the long post. So, somehow, I got VMD installed successfully.
Then I tried re-running the tutorial this time using VMD for
visualization, but here is what happened; an xterm terminal opens with
the message:

xterm: Can't execvp /usr/local/lib/vmd/vmd_LINUX: No such file or directory

In fact this is the content of the folder which is giving me some headache:

 ls /usr/local/lib/vmd/
Announcement  doc  LICENSE  plugins  README  scripts  shaders

Can anyone help me out? I am sure there must be other Debian/Ubuntu
users  or simply people building from source who went through
this...and I am also sure that if has to be rather trivial to sort
this out, for someone knowledgeable.
Many thanks


reply via email to

[Prev in Thread] Current Thread [Next in Thread]