[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo] MPI issue

From: Tristan Bereau
Subject: Re: [ESPResSo] MPI issue
Date: Wed, 03 Oct 2007 12:03:11 -0400
User-agent: Thunderbird (X11/20070801)


Thanks for your help. Unfortunately the CC=mpicc argument didn't quite
help, but I think I found something interesting:
The compiler settings at the end of the ./configure process gives me:

Compiler settings:
MPI                     = mpich
compiler                = mpicc
linker                  = mpicc
c compiler flags        = -finline-limit=1000000 -fomit-frame-pointer
-funroll-loops -floop-optimize -ffast-math -Wall -Wno-unused-function
-O3 -malign-double -msse2 -mfpmath=sse -march=nocona
c preprocessor flags    =  -I/opt/mpich/include
linker flags            =  -L/opt/mpich/ch-p4/lib
libraries               = -lfftw3  -ltcl8.4  -lmpich -lm
using debug flags       = no
using profiling flags   = no
inline                  =

I think the problem comes from the 'MPI = mpich' line.  Even if mpicc is
set in the environment by OpenMPI (I checked using a 'which' command),
ESPResSo links to 'mpich' in the directory /opt/mpich.
I just discovered right now that mpich and openMPI are two different
programs, so I'm guessing I had mpich by default on my computer and it's
just not compatible with ESPResSo...

I'm a little bothered ESPResSo references to mpich, since I added
openmpi at the beginning of my $PATH variable.
I'll look more into that.

Thanks anyway for your suggestion!


Ulf Schiller wrote:
> Hi Tristan,
> Tristan Bereau wrote:
> > Thanks for your answer.
> > I looked at the config.log (attached). First, it looks like mpirun,
> > mpicc, and mpich are recognized pretty much everywhere in the file.
> > But looking carefully towards the end of the file (~line 1200),
> there is:
> > which doesn't look right to me at all (unless a '#' sign means a
> 'no'...?)!
> > It's strange, because it did find all the relevant mpi files on my
> computer.
> > I tried reinstalling OpenMPI (1.2.3), but it still does the same
> problem.
> Thanks for providing the config.log. It seems indeed that ESPResSo's
> build system does not recognize the MPI environment correctly. As far as
>  I know, not many of us have used ESPResSo with OpenMPI so far. On the
> one hand, this means that it may take some time until your problem can
> be fixed, on the other hand your reports are of great help to improve
> ESPResSo.
> > Is there some trick to solve that?
> I'm not an expert in the build system so I can only make a guess: My
> suspicion is that the dependency mode set by configure is not correct:
> CC='mpicc'
> CCDEPMODE='depmode=gcc3'
> Can you try to configure ESPResSo again with
> ./configure CC=mpicc
> and check whether the values of these variables change?
> I had a similar problem recently which could be solved this way. I'm not
> sure whether it'll solve your problem as well, but it's worth a try...
> Many regards,
> Ulf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]