[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: flexisip_pusher not working.

From: Mikhail Sviridov
Subject: RE: flexisip_pusher not working.
Date: Wed, 18 Mar 2020 16:00:32 +0000

Hi Peio,


Thank you very much for the answer.

Just for the clarification – do I need to put the app id in form of file or should it be just some triplet? (like com.something.somewhere ?) If it is file – where can I generate this file? Do I need to put this file into /etc/flexisip/apn ?


BTW is there any manual how to configure the push notification available? (beside this one: https://wiki.linphone.org/xwiki/wiki/public/view/Flexisip/Configuration/)


With Best Regards,



Sent from Mail for Windows 10


From: Peio Rigaux
Sent: Wednesday, March 18, 2020 6:50 PM
To: address@hidden
Subject: Re: flexisip_pusher not working.


Hi Mikhail.

Just a quick answer as you seems to have a typo in your command.

"flexisip_pusher --pntype apple --appid key_file.pem –pntok xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx --debug"

You give the key_file.pem as an argument to --appid options. This is incorrect.

You should give to this argument your appid (and have a [your appid].pem file in the right directory, /etc/flexisip/apn by default)

Please use this command instead :

flexisip_pusher --pntype apple --appid [your app id] --debug –pntok xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx



Peio Rigaux
Junior Software Engineer
Belledonne Communications, the company behind Linphone

Le 18/03/2020 à 15:27, Mikhail Sviridov a écrit :

Hi Everyone,


I solved all previous problems and flexisip is working as it should. Now I got to the next problem – push notification.


I followed (very brief) instructions about push notification configuration, but if did not work. I tried flexisip_pusher and got following debug messages:


user@server:~$ flexisip_pusher --pntype apple --appid key_file.pem –pntok xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx --debug

Writing logs in : /var/opt/belledonne-communications/log/flexisip/flexisip-pusher.log

2020-03-18 14:06:30:320 flexisip-debug-Searching push notification client on dir [/etc/flexisip/apn]

2020-03-18 14:06:30:321 flexisip-debug-Certificate /etc/flexisip/apn/key_file.pem has a valid expiration: Mar  9 07:48:40 2021 GMT.

2020-03-18 14:06:30:321 flexisip-debug-Adding ios push notification client [key_file]

2020-03-18 14:06:30:322 flexisip-debug-PNR 0x563b21d88dc0 payload is {"aps":{"alert":{"loc-key":"IM_MSG","loc-args":["Pusher"]},"sound":"msg.caf","badge":1},"call-id":"","pn_ttl":2592000,"uuid":"","send-time":"2020-03-18 14:06:30"}

2020-03-18 14:06:30:322 flexisip-error-No push notification client available for push notification request : 0x563b21d88dc0

Segmentation fault


What should I have in the /etc/flexisip/apn/ beside the key file? Should I rename key_file.pem in some “porper” name?


BTW when I ran flexisip as proxy I got following debug:

2020-03-18 13:43:27:925 flexisip-debug-Searching push notification client on dir [/etc/flexisip/apn]

2020-03-18 13:43:27:925 flexisip-debug-Adding ios push notification client [key_file]


Does it mean flexisip itself did find “push notification client”? What is wrong with flexisip_pusher?


With Best Regards,


P.S. If someone interested in working configuration file (simple SIP proxy) I can share it here…



Sent from Mail for Windows 10



reply via email to

[Prev in Thread] Current Thread [Next in Thread]