[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: flexisip_pusher not working.

From: Mikhail Sviridov
Subject: RE: flexisip_pusher not working.
Date: Wed, 18 Mar 2020 16:35:13 +0000

Hi Joel,


Here is the anonymized configuration file. (See attached file).

This version has push notification off. Also beware of filters. Before I put my domain in those filters there were no sound and no video. Also beware of the small issues in there. Some are very important. Later I will try to recall what was the important issues just to make those working. Also not to forget – the most recent flexisip does not work with odbc anymore, it uses soci instead. File also possible, but format of the file with accounts is very strict and error messages are not very good – you can have error in second line but error message will point on first line. I did use Debian 10 but Debian 9 (Stretch) would be better choice, because Debian 10 has it’s problems. MySQL 5.7 is also better choice and do not use modern plugins for “flexisip” user – use legacy. Also do not forget about debugs. Use those only if needed, you can get 1GB debugs in couple hours easily.


With Best Regards,



Sent from Mail for Windows 10


From: Joel Linn
Sent: Wednesday, March 18, 2020 6:24 PM
To: address@hidden
Subject: Re: flexisip_pusher not working.



Just for clarification, did you build your own custom linphone ios app
with your push keys?
Are you able to share your (anonymized) configuration file with us?

Best Regards,

Joel Linn

On 2020-03-18 15:27, Mikhail Sviridov wrote:

> Hi Everyone,
> I solved all previous problems and flexisip is working as it should.
> Now I got to the next problem - push notification.
> I followed (very brief) instructions about push notification
> configuration, but if did not work. I tried flexisip_pusher and got
> following debug messages:
> user@server:~$ flexisip_pusher --pntype apple --appid key_file.pem
> -pntok
> xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
> --debug
> Writing logs in :
> /var/opt/belledonne-communications/log/flexisip/flexisip-pusher.log
> 2020-03-18 14:06:30:320 flexisip-debug-Searching push notification
> client on dir [/etc/flexisip/apn]
> 2020-03-18 14:06:30:321 flexisip-debug-Certificate
> /etc/flexisip/apn/key_file.pem has a valid expiration: Mar  9 07:48:40
> 2021 GMT.
> 2020-03-18 14:06:30:321 flexisip-debug-Adding ios push notification
> client [key_file]
> 2020-03-18 14:06:30:322 flexisip-debug-PNR 0x563b21d88dc0 payload is
> {"aps":{"alert":{"loc-key":"IM_MSG","loc-args":["Pusher"]},"sound":"msg.caf","badge":1},"call-id":"","pn_ttl":2592000,"uuid":"","send-time":"2020-03-18
> 14:06:30"}
> 2020-03-18 14:06:30:322 flexisip-error-No push notification client
> available for push notification request : 0x563b21d88dc0
> Segmentation fault
> What should I have in the /etc/flexisip/apn/ beside the key file?
> Should I rename key_file.pem in some "porper" name?
> BTW when I ran flexisip as proxy I got following debug:
> 2020-03-18 13:43:27:925 flexisip-debug-Searching push notification
> client on dir [/etc/flexisip/apn]
> 2020-03-18 13:43:27:925 flexisip-debug-Adding ios push notification
> client [key_file]
> Does it mean flexisip itself did find "push notification client"? What
> is wrong with flexisip_pusher?
> With Best Regards,
> Mikhail.
> P.S. If someone interested in working configuration file (simple SIP
> proxy) I can share it here...
> Sent from Mail for Windows 10


Attachment: flexisip_anonymized.conf
Description: flexisip_anonymized.conf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]