[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Qsynth broken with FluidSynth 1.1.0

From: David Henningsson
Subject: Re: [fluid-dev] Qsynth broken with FluidSynth 1.1.0
Date: Tue, 03 Nov 2009 17:04:59 +0100
User-agent: Thunderbird (X11/20090817)

Rui Nuno Capela wrote:
i am sorry to chime in this late, but qsynth won't support this fluidsynth


first of all build fails due to (const char *) api change.

Right, I'll let Josh answer to this, I thought he only changed the input API, not the callbacks. But that is easily fixed in QSynth, I can supply a patch against qsynth if you like.

second, qsynth behaves very badly, inconsistently and troublesome against
1.1.0. everything just feels broken.

Can you explain this a bit?

I haven't used QSynth much, but I fixed the const char* stuff (in qsynth 0.3.4, ubuntu version) and built it against current svn. And I got Fluidsynth up and working in qsynth and it seemed quite responsive when I played on my piano, and that was actually even without a real-time kernel or rtprio. I tried changing the reverb and it worked fine.

it's a pity :( 1.1.0 seemed a good step forward but i'm afraid i will
avoid it for quite some time, at least until i have some and rewrite qsynth
from the ground up. or else, let qsynth simply rot to oblivion ...

Do you think you need do do more than change the const char* stuff?

// David

reply via email to

[Prev in Thread] Current Thread [Next in Thread]