[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] possible 1.1.3 bug

From: Max McCracken
Subject: Re: [fluid-dev] possible 1.1.3 bug
Date: Wed, 20 Oct 2010 09:22:51 +0400

On Wed, Oct 20, 2010 at 7:31 AM, Matt Giuca <address@hidden> wrote:
> Hey Max,
>> Last time I used fluidsynth to render midis was in january 2010 I
>> think (I used the version in ubuntu 10.04, don't remember the number).
>> Everything was fine. However after I updated to 1.1.1 (the current
>> Ubuntu default), I had the "all instruments are pianos" bug and
>> decided to update to 1.1.2. After I updated the pianos bug vanished
>> but it appears another one is here.
> Well as far as I know, 1.1.1 was always the version of FluidSynth included
> with Ubuntu 10.04 (Lucid). When you say "the current Ubuntu default" are you
> referring to 10.04 still (which is still at FluidSynth 1.1.1)? Because
> Ubuntu 10.10 (Maverick; which came out a week ago) has FluidSynth 1.1.2
> included.
> Wait, you say January 2010 -- I assume therefore you mean you used the
> version in Ubuntu 9.10 (Karmic), which was FluidSynth 1.0.9 according to
> http://packages.ubuntu.com/karmic/sound/fluidsynth

No, I never had Ubuntu 9.10. But I found out what the problem is, check below.

>> This midi file
>> https://sites.google.com/site/metaruka/GameGame/01Game-Game.mid?attredirects=0
>> with this soundfont
>> ftp://ftp.personalcopy.net/pub/RealFont_2_1.sfArk
>> renders with lead synth sounding distinctly off-note (however sounding
>> okay with 8MBGMSFX.SF2)
> I can't get to that FTP site (the second link) -- it seems the server is
> down. Can you upload the SF to dropbox like you did with the ogg file?

Here's the link:

>> I tried downloading and compiling older versions of fluidsynth but
>> they strangely behave the same way as the new one (I also checked the
>> 1.1.3). Is there something I'm missing?
> That's weird. If you can't reproduce the "good" music even with an older
> version of FluidSynth, then perhaps something else has changed? Maybe the
> MIDI file, the soundfont, or the parameters have changed since you last
> recorded the music in January? Have you specifically tried it with
> FluidSynth 1.0.9?

Okay, what I did was change Ubuntu 10.04 32-bit -> 64-bit sometime
this year (to be clear, I'm speaking about VirtualBox VMs, none of my
Ubuntus are/were on host machine). I tried to render the midi file in
1.1.1 and it had piano bug. I updated to 1.1.2 from your unofficial
ppa on launchpad and notes for some instruments started to be off-key.
Just to be sure I booted the clean Ubuntu 10.04 32-bit VM, updated to
1.1.2 from your ppa (1.1.1 has piano bug, too) and what do you know,
it works fine. So I'm assuming the problem lies somewhere in 64-bit
compiled code.

Also, the bug persists in 1.1.3 - I compiled it from sources to check.

The command I use to test:
fluidsynth -i -l -r 48000 -a alsa RealFont_2_1.sf2 01Game-Game.mid

On 32-bit VM it plays fine, on 64-bit gives off-key notes. There's a
very slight chance it's somehow VirtualBox bug but I wouldn't bet on
it, the wave rendering goes before outputting the sound stream and
rhythm/drums sound fine in both cases.

> Sorry I can't be more helpful. Hope these questions help you discover
> something more about this problem.
> Matt

reply via email to

[Prev in Thread] Current Thread [Next in Thread]