[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] possible 1.1.3 bug

From: Max McCracken
Subject: Re: [fluid-dev] possible 1.1.3 bug
Date: Wed, 20 Oct 2010 10:10:22 +0400

On Wed, Oct 20, 2010 at 9:39 AM, Matt Giuca <address@hidden> wrote:
>> Okay, what I did was change Ubuntu 10.04 32-bit -> 64-bit sometime
>> this year (to be clear, I'm speaking about VirtualBox VMs, none of my
>> Ubuntus are/were on host machine). I tried to render the midi file in
>> 1.1.1 and it had piano bug. I updated to 1.1.2 from your unofficial
>> ppa on launchpad and notes for some instruments started to be off-key.
>> Just to be sure I booted the clean Ubuntu 10.04 32-bit VM, updated to
>> 1.1.2 from your ppa (1.1.1 has piano bug, too) and what do you know,
>> it works fine.
> Ah cool, so that PPA was useful then :) Note that my PPA has since been

Sure, it's way more convenient to use apt instead of compiling from sources :)

> superseded by a native 1.1.2 package in Ubuntu 10.10.

As soon as I get around to upgrading... :)

>> So I'm assuming the problem lies somewhere in 64-bit
>> compiled code.
> Ah, then that does sound like a bug in the 64-bit version. I haven't got a
> 64-bit OS set up to test it on.

You can set up a 64-bit VirtualBox VM even on 32-bit host afaik if you need it.

>> On 32-bit VM it plays fine, on 64-bit gives off-key notes. There's a
>> very slight chance it's somehow VirtualBox bug but I wouldn't bet on
>> it, the wave rendering goes before outputting the sound stream and
>> rhythm/drums sound fine in both cases.
> I doubt it's a virtualisation problem, since you are (or at least in your
> last email, were) rendering to a file, which means it's unrelated to the
> virtual hardware or timing (the faster-than-realtime mode of FluidSynth
> doesn't use the system timer, as far as I know, it just computes the final
> wave file and outputs it). In the most recent email, you used -a alsa to
> test, which would be more susceptible to virtual hardware issues. I assume

Well, if fluidsynth mixed using alsa ...

> you also tried it with -F in 1.1.3.

Yep, I tried that.

> (Btw I am not a FluidSynth developer, I'm just interested.)

Oh? Should I also post a bug report somewhere then?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]