[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] qsynth 0.3.6 for mac osx

From: Ebrahim Mayat
Subject: Re: [fluid-dev] qsynth 0.3.6 for mac osx
Date: Thu, 14 Apr 2011 13:47:08 -0400

On Apr 13, 2011, at 5:25 PM, Pedro Lopez-Cabanillas wrote:

I've attached a document containing the terminal output and the qsynth console output when lauching qsynth with the following commands:

$ open qsynth.app


The Terminal.app outputs from both your setup and mine are identical.

Your console output looks normal, except for the line that says "Failed to load the soundfont". Anyway, there is not much information there to debug your problem, but I have some suspects: 

* your system is loading some libraries from somewhere instead of the frameworks included in the bundle. To debug this, you can execute the following commands in a terminal window and send me the output from the terminal and from qsynth messages window. There shouldn't be any referenced libraries except Mac OSX system ones.

$ open qsynth.app

Again, my Terminal.app output is the same as above but the qsynth messages window reveals that on my machine, the JackRouter plugin and Jackmp framework  are also dynamically linked in addition to the system libs. I removed Jack but I still get the "Failed to load SoundFont" scenario. So Jack is not the cause. 

dyld: loaded: /System/Library/PrivateFrameworks/Shortcut.framework/Versions/A/Shortcut
dyld: loaded: /System/Library/PrivateFrameworks/HelpData.framework/Versions/A/HelpData

06:29:50.517 Qsynth1: Creating synthesizer engine...
06:29:50.600 Qsynth1: Loading soundfont: "/Users/login/Library/Audio/Sounds/Banks/FluidR3_GM.SF2" (bank offset 0)...
06:29:50.606 Qsynth1: Failed to load the soundfont: "/Users/login/Library/Audio/Sounds/Banks/FluidR3_GM.SF2".
dyld: loaded: /System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn
dyld: loaded: /System/Library/Extensions/IOAudioFamily.kext/Contents/PlugIns/AOAHALPlugin.bundle/Contents/MacOS/AOAHALPlugin
dyld: loaded: /Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter
dyld: loaded: /Library/Frameworks/Jackmp.framework/Versions/A/Jackmp
fluidsynth: error: Couldn't load soundfont file
fluidsynth: error: Failed to load SoundFont "/Users/login/Library/Audio/Sounds/Banks/FluidR3_GM.SF2"

* there is something in fluidsynth-SVN code that fails when loading soundfonts in your machine. To test this hypothesis, download fluidsynth from SVN (for instance:  http://fluidsynth.svn.sourceforge.net/viewvc/fluidsynth/?view=tar ) and compile it in the same computer. Does it load soundfonts?

Yes, it does but as I had reported some weeks back, fluidsynth cannot render MIDI files. FS begins with a "pop" and is then silent. One other thing I noticed is that when fluidsynth starts there is an enormous spike in CPU usage (Please find attached readings of top sampled at intervals of 2 seconds). This spike maxes out the PPC CPU. It would seem that the older slower PPC CPUs cannot cope with this enormous surge in CPU utilisation.  

My FS invocation was $ fluidsynth -a coreaudio ~/Library/Audio/Sounds/Banks/FluidR3_GM.SF2 ~/Music/MIDI/drum_patterns/ROCK.MID

I ran the benchmarking script in a second Terminal.app window.  
$ source ~/Desktop/logscript.sh > FSlog

Lets try that first, before using instruments/dtrace utilities to dig deeper.

You could run fluidsynth on Linux using valgrind for profiling and to check for any memory leaks.

On Apr 14, 2011, at 11:32 AM, Sven Meier wrote:

here's my report:

Fluidsynth starts and is loading the Soundfont correctly. Connecting VMPK with Fluidsynth, the Midi indicator flashes and the messages dialog is filled with fluidsynth:noteoff/fluidsynth:noteon confirmations.

- no sound, no activity on the peak level meter either.
- after a while playing the virtual keyboard the messages dialog is
flooded with event_pre_noteoff/event_post_noteoff messages,
- then the following messages appears for each key press:
 fluidsynth: warning: Failed to allocate a synthesis process

Guten Tag Sven, 

You mean qsynth :-) 

So you also have a sound rendering problem.

My own build of Fluidsynth is working flawlessly on my machine.

What happens when you try and render a MIDI file using FluidSynth ? (I am also attaching the MIDI file and the benchmarking script I used.)


Attachment: FSlog
Description: Binary data

Attachment: logscript.sh
Description: Binary data

Attachment: ROCK.MID
Description: MIDI audio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]