[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compilation problem with mumps

From: edgar
Subject: Re: Compilation problem with mumps
Date: Mon, 24 May 2021 16:29:36 +0000
User-agent: Roundcube Webmail

Hi, Pierre. Disclaimer: I haven't been able to compile the test suite correctly (take my advice with reserves).

The sequential libraries of MUMPS usually have _seq before the .o . I can imagine that you already checked that you have the right libraries. By the looks of it, you are using the parallel version, but I don't dare to draw such conclusion. This comes from the configure file, and you might want to try it:

    "-lsmumps_seq -ldmumps_seq -lcmumps_seq -lzmumps_seq"

I remember that I was able to hijack the library files with a variable (MUMPS_LIBS?), but I am sure that the developers will have much better advice than this.

Bonne chance!

On 2021-05-24 15:48, pierre.gosselet wrote:
Dear all,
I am working on a cluster and I need to compile getfem and most of its

I have a hard time compiling the mumps support. I know close questions
were already asked but I did not find the answer. Sorry if I missed it.

I compiled sequential mumps without trouble, examples work fine.

I tried to configure getfem with:
./configure --enable-mumps --with-mumps-include-
dir="$MUMPS_DIR/include" --with-mumps="-fopenmp -lsmumps -lmumps_common
-ldmumps -lcmumps -lzmumps -lpord -lesmumps -lscotch -lscotcherr -
llapack -lmpiseq -lblas -lpthread" --with-pic

I always have the following problem:
checking for library containing smumps_c... no
configure: error: The function smumps_c couldn't be found in the
provided MUMPS libraries.

The --with-mumps is inspired by the compilation line for mumps examples
(I have copied the libseq includes file in the include directory).
All the libraries are in the $LD_LIBRARY_PATH, but I also tried with
the full path. $MUMPS_DIR is well defined. I also tried with the mumps
module provided by the cluster's administrator (with adapted include),
same problem.

Can anyone help me ?

best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]