[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] tla panic

From: Na Li
Subject: Re: [Gnu-arch-users] tla panic
Date: Wed, 12 May 2004 11:52:36 -0500
User-agent: Emacs Gnus

On 12 May 2004, Aaron Bentley verbalised:

Na Li wrote:
> > I'm using tla 1.2 on Mac OX 10.3.3.  Now and then I got this: bass$
> > tla file-diffs Wiki/Teaching/BiostatOne/ConceptsTechniquesReview
> > PANIC: execvp for diff returned to caller It is just plain text file
> > but tla seems to regard it as binary.  Google search didn't bring
> > anything useful.  Any idea what went wrong?
> tla uses diff to determine whether files are binary or not.  Apparently,
> diff considers a file to be binary if it contains the ASCII NUL
> character (0x00).  Is it possibly a UTF-16 file?  Those files usually
> contain a byte-order mark, which contains an 0x00, IIRC.

Thanks for the reply.

The files in question are not a UTF-16, just plain ASCII files, (which
Emacs uses 'undecided-unix' encoding).  I can run diff manually with the
pristine copy just fine.

BTW, I have tried two different versions of diffutils: 2.7 which ships
with Mac OS X Panther and 2.8.1 installed from Fink.  Both give the same
results.  I've also tried to recompile tla from the latest archive with no


reply via email to

[Prev in Thread] Current Thread [Next in Thread]